summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 22:22:52 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 22:22:52 +0000
commited74e3cfb156c40ae8684972e08edbc1852ce25d (patch)
tree1b689846f8ecb55ca3936b3a1c1c00bde929bb86 /dev-python/pycdf
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-ed74e3cfb156c40ae8684972e08edbc1852ce25d.tar.gz
gentoo-2-ed74e3cfb156c40ae8684972e08edbc1852ce25d.tar.bz2
gentoo-2-ed74e3cfb156c40ae8684972e08edbc1852ce25d.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycdf')
-rw-r--r--dev-python/pycdf/ChangeLog8
-rw-r--r--dev-python/pycdf/pycdf-0.6.3.ebuild22
2 files changed, 20 insertions, 10 deletions
diff --git a/dev-python/pycdf/ChangeLog b/dev-python/pycdf/ChangeLog
index fa66e2af97dc..e1340b326c91 100644
--- a/dev-python/pycdf/ChangeLog
+++ b/dev-python/pycdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycdf
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdf/ChangeLog,v 1.9 2007/06/14 14:10:47 lucass Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdf/ChangeLog,v 1.10 2010/07/23 22:22:52 arfrever Exp $
+
+ 23 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pycdf-0.6.3.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*pycdf-0.6.3 (14 Jun 2007)
diff --git a/dev-python/pycdf/pycdf-0.6.3.ebuild b/dev-python/pycdf/pycdf-0.6.3.ebuild
index d8c1735f7c75..52bb0364dc59 100644
--- a/dev-python/pycdf/pycdf-0.6.3.ebuild
+++ b/dev-python/pycdf/pycdf-0.6.3.ebuild
@@ -1,22 +1,28 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdf/pycdf-0.6.3.ebuild,v 1.1 2007/06/14 14:10:47 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdf/pycdf-0.6.3.ebuild,v 1.2 2010/07/23 22:22:52 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-MY_P=${PN}-${PV:0:3}-${PV:4:1}
+MY_P="${PN}-${PV:0:3}-${PV:4:1}"
DESCRIPTION="Python interface to scientific netCDF library."
HOMEPAGE="http://pysclint.sourceforge.net/pycdf/"
SRC_URI="mirror://sourceforge/pysclint/${MY_P}.tar.gz"
-IUSE="examples"
+LICENSE="PYTHON"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
-LICENSE="PYTHON"
+IUSE="examples"
-DEPEND=">=sci-libs/netcdf-3.6.1
- dev-python/numpy"
+DEPEND="dev-python/numpy
+ >=sci-libs/netcdf-3.6.1"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -28,6 +34,6 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r examples
+ doins -r examples || die "doins failed"
fi
}