summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-14 00:14:18 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-14 00:14:18 +0000
commitc96600103d17bc86d3f8102e1c89c0a2fd932d2c (patch)
treef47e66b2c00e2cf80490f244c59fab0443c12098 /dev-python/pyatspi
parentAdd pyatspi to gnome-3.4 mask. (diff)
downloadgentoo-2-c96600103d17bc86d3f8102e1c89c0a2fd932d2c.tar.gz
gentoo-2-c96600103d17bc86d3f8102e1c89c0a2fd932d2c.tar.bz2
gentoo-2-c96600103d17bc86d3f8102e1c89c0a2fd932d2c.zip
Version bump for gnome-3.4
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/ChangeLog8
-rw-r--r--dev-python/pyatspi/pyatspi-2.4.0.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-python/pyatspi/ChangeLog b/dev-python/pyatspi/ChangeLog
index 3613f8ec3704..12084a49d15c 100644
--- a/dev-python/pyatspi/ChangeLog
+++ b/dev-python/pyatspi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyatspi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.9 2012/05/04 15:12:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.10 2012/05/14 00:14:18 tetromino Exp $
+
+*pyatspi-2.4.0 (14 May 2012)
+
+ 14 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +pyatspi-2.4.0.ebuild:
+ Version bump for gnome-3.4
04 May 2012; Patrick Lauer <patrick@gentoo.org> pyatspi-2.2.1.ebuild:
Migrating dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-python/pyatspi/pyatspi-2.4.0.ebuild b/dev-python/pyatspi/pyatspi-2.4.0.ebuild
new file mode 100644
index 000000000000..949f8500f62f
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.4.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.4.0.ebuild,v 1.1 2012/05/14 00:14:18 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.* *-jython"
+
+inherit gnome2 python
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="test"
+
+COMMON_DEPEND="dev-python/dbus-python
+ >=dev-python/pygobject-2.90.1:3
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-${PV}[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? (
+ >=dev-libs/atk-2.1.0
+ >=dev-libs/dbus-glib-0.7
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ >=x11-libs/gtk+-2.10:2 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable test tests)"
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ python_clean_py-compile_files
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup pyatspi
+}