summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-14 13:31:41 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-14 13:31:41 +0000
commitc6cba25fbec2b62a169b47d34bc6506e64945d07 (patch)
treec0ca28148c1e7a007245f443e679a7ee65497085 /dev-python/psycopg
parentRemove rdepend on npapi-sdk, as it just provides headers during the build. (diff)
downloadgentoo-2-c6cba25fbec2b62a169b47d34bc6506e64945d07.tar.gz
gentoo-2-c6cba25fbec2b62a169b47d34bc6506e64945d07.tar.bz2
gentoo-2-c6cba25fbec2b62a169b47d34bc6506e64945d07.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/ChangeLog7
-rw-r--r--dev-python/psycopg/psycopg-2.4.6-r1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index cfbb17cff2d0..9345d859b3ed 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.152 2013/01/11 07:48:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.153 2013/01/14 13:31:41 mgorny Exp $
+
+*psycopg-2.4.6-r1 (14 Jan 2013)
+
+ 14 Jan 2013; Michał Górny <mgorny@gentoo.org> +psycopg-2.4.6-r1.ebuild:
+ Migrate to distutils-r1.
*psycopg-2.4.6 (11 Jan 2013)
diff --git a/dev-python/psycopg/psycopg-2.4.6-r1.ebuild b/dev-python/psycopg/psycopg-2.4.6-r1.ebuild
new file mode 100644
index 000000000000..00c704fd2389
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.4.6-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.6-r1.ebuild,v 1.1 2013/01/14 13:31:41 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples"
+
+RDEPEND=">=dev-db/postgresql-base-8.1"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile() {
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+
+ [[ ${EPYTHON} != python3* ]] && append-flags -fno-strict-aliasing
+
+ distutils-r1_python_compile
+}
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-2.4.2-setup.py.patch"
+ "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+ )
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
+ fi
+
+# if use mxdatetime; then
+# sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die
+# fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc -j1 html text
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc doc/{HACKING,SUCCESS}
+
+ if use doc; then
+ dodoc doc/psycopg2.txt
+ dohtml doc/html/.
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/.
+ fi
+}