summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-11 07:32:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-11 07:32:32 +0000
commit29cc1622a3260f5fe80de345f0c5b7c36989675f (patch)
tree2bfc1c1191f6b6b02050f1bdc1e8c8e5063b9627 /dev-python/pp/pp-1.6.3.ebuild
parentFixed download location of patchset. (diff)
downloadgentoo-2-29cc1622a3260f5fe80de345f0c5b7c36989675f.tar.gz
gentoo-2-29cc1622a3260f5fe80de345f0c5b7c36989675f.tar.bz2
gentoo-2-29cc1622a3260f5fe80de345f0c5b7c36989675f.zip
Bump for #451224
(Portage version: 2.2.0_alpha150/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pp/pp-1.6.3.ebuild')
-rw-r--r--dev-python/pp/pp-1.6.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pp/pp-1.6.3.ebuild b/dev-python/pp/pp-1.6.3.ebuild
new file mode 100644
index 000000000000..ad70c4cdebe0
--- /dev/null
+++ b/dev-python/pp/pp-1.6.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pp/pp-1.6.3.ebuild,v 1.1 2013/01/11 07:32:32 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Parallel and distributed programming for Python"
+HOMEPAGE="http://www.parallelpython.com/"
+SRC_URI="http://www.parallelpython.com/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="pp.py ppauto.py pptransport.py ppworker.py"
+
+src_install() {
+ distutils_src_install
+
+ doman doc/ppserver.1
+ use doc && dohtml doc/ppdoc.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}/examples"
+ fi
+}