summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-02 08:47:29 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-02 08:47:29 +0000
commit7f9affb26713f5d06208a9f456676000e3ce35d8 (patch)
tree703c76a2498f0128d8f5957c06d6d43a30293dd0 /dev-python/pip
parentDrop mask for dev-tex/mh after package removal. (diff)
downloadgentoo-2-7f9affb26713f5d06208a9f456676000e3ce35d8.tar.gz
gentoo-2-7f9affb26713f5d06208a9f456676000e3ce35d8.tar.bz2
gentoo-2-7f9affb26713f5d06208a9f456676000e3ce35d8.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-7.0.3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 0ff0a51a8838..ebdd47efb90e 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.65 2015/06/02 05:16:02 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.66 2015/06/02 08:47:29 jlec Exp $
+
+*pip-7.0.3 (02 Jun 2015)
+
+ 02 Jun 2015; Justin Lecher <jlec@gentoo.org> +pip-7.0.3.ebuild:
+ Version Bump
02 Jun 2015; Jack Morgan <jmorgan@gentoo.org> pip-1.5.6.ebuild:
sparc stable wrt bug #540290
diff --git a/dev-python/pip/pip-7.0.3.ebuild b/dev-python/pip/pip-7.0.3.ebuild
new file mode 100644
index 000000000000..aa5f24de8bdf
--- /dev/null
+++ b/dev-python/pip/pip-7.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-7.0.3.ebuild,v 1.1 2015/06/02 08:47:29 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch )
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}