summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-16 08:20:30 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-16 08:20:30 +0000
commited69fb79d3005d0ade4edc146e6be14232213c98 (patch)
tree944d415bd2cf0336874a2bcaefae645e47d8131e /dev-python/pastedeploy
parentVersion bump webob to 1.1. (diff)
downloadgentoo-2-ed69fb79d3005d0ade4edc146e6be14232213c98.tar.gz
gentoo-2-ed69fb79d3005d0ade4edc146e6be14232213c98.tar.bz2
gentoo-2-ed69fb79d3005d0ade4edc146e6be14232213c98.zip
Version bump pastedeploy to 1.5.0.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pastedeploy')
-rw-r--r--dev-python/pastedeploy/ChangeLog9
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.0.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/pastedeploy/ChangeLog b/dev-python/pastedeploy/ChangeLog
index 0173b8c583d7..65b02977988b 100644
--- a/dev-python/pastedeploy/ChangeLog
+++ b/dev-python/pastedeploy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pastedeploy
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.9 2010/06/26 04:41:35 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.10 2011/09/16 08:20:30 djc Exp $
+
+*pastedeploy-1.5.0 (16 Sep 2011)
+
+ 16 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> +pastedeploy-1.5.0.ebuild:
+ Version bump to 1.5.0 (fixes bug 382917, thanks jbergstroem).
26 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pastedeploy-1.3.3.ebuild:
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.0.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.0.ebuild
new file mode 100644
index 000000000000..8fd77864b025
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-1.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.5.0.ebuild,v 1.1 2011/09/16 08:20:30 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="http://pythonpaste.org/deploy/ http://pypi.python.org/pypi/PasteDeploy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/paste
+ dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="paste/deploy"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc "${S}"/docs/*.txt || die
+ fi
+}