summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-01-27 22:05:54 +0000
committerMike Frysinger <vapier@gentoo.org>2015-01-27 22:05:54 +0000
commit9b40498826afc3a681f6f67afcb5f2b6f1ddeec7 (patch)
tree24629fa55fff54914aee6b04effd216c23bcd470 /dev-python/oauth2client
parentFix RDEPEND for binary packages. (diff)
downloadgentoo-2-9b40498826afc3a681f6f67afcb5f2b6f1ddeec7.tar.gz
gentoo-2-9b40498826afc3a681f6f67afcb5f2b6f1ddeec7.tar.bz2
gentoo-2-9b40498826afc3a681f6f67afcb5f2b6f1ddeec7.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-python/oauth2client')
-rw-r--r--dev-python/oauth2client/ChangeLog10
-rw-r--r--dev-python/oauth2client/oauth2client-1.4.6.ebuild37
2 files changed, 44 insertions, 3 deletions
diff --git a/dev-python/oauth2client/ChangeLog b/dev-python/oauth2client/ChangeLog
index ed7c0da9c048..70e315f7de9b 100644
--- a/dev-python/oauth2client/ChangeLog
+++ b/dev-python/oauth2client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oauth2client
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauth2client/ChangeLog,v 1.3 2014/12/30 17:43:38 maekke Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauth2client/ChangeLog,v 1.4 2015/01/27 22:05:54 vapier Exp $
+
+*oauth2client-1.4.6 (27 Jan 2015)
+
+ 27 Jan 2015; Mike Frysinger <vapier@gentoo.org> +oauth2client-1.4.6.ebuild:
+ Version bump.
30 Dec 2014; Markus Meier <maekke@gentoo.org> oauth2client-1.4.2.ebuild:
add ~arm, bug #531816
@@ -13,4 +18,3 @@
06 Dec 2014; Justin Lecher <jlec@gentoo.org> +oauth2client-1.4.2.ebuild,
+metadata.xml:
New addition, written by me
-
diff --git a/dev-python/oauth2client/oauth2client-1.4.6.ebuild b/dev-python/oauth2client/oauth2client-1.4.6.ebuild
new file mode 100644
index 000000000000..ae93982c554e
--- /dev/null
+++ b/dev-python/oauth2client/oauth2client-1.4.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauth2client/oauth2client-1.4.6.ebuild,v 1.1 2015/01/27 22:05:54 vapier Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
+HOMEPAGE="https://github.com/google/oauth2client"
+SRC_URI="https://github.com/google/oauth2client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Needs network
+RESTRICT=test
+
+python_test() {
+ nosetests || die
+}