summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-05 16:41:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-05 16:41:43 +0000
commit5a712bbaebebb7797788646a26fe19bdf25a2683 (patch)
tree43ebadc486ef321acb7b189cf4a871d921e06ba5 /dev-python/oauth2
parentRestrict Jython ABIs. Update HOMEPAGE. (diff)
downloadgentoo-2-5a712bbaebebb7797788646a26fe19bdf25a2683.tar.gz
gentoo-2-5a712bbaebebb7797788646a26fe19bdf25a2683.tar.bz2
gentoo-2-5a712bbaebebb7797788646a26fe19bdf25a2683.zip
Version bump.
(Portage version: 2.2.0_alpha30_p50/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/oauth2')
-rw-r--r--dev-python/oauth2/ChangeLog8
-rw-r--r--dev-python/oauth2/oauth2-1.5.170.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/oauth2/ChangeLog b/dev-python/oauth2/ChangeLog
index 4b05e5d557a1..5a333ba25395 100644
--- a/dev-python/oauth2/ChangeLog
+++ b/dev-python/oauth2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/oauth2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauth2/ChangeLog,v 1.3 2011/05/04 07:25:31 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauth2/ChangeLog,v 1.4 2011/05/05 16:41:43 arfrever Exp $
+
+*oauth2-1.5.170 (05 May 2011)
+
+ 05 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +oauth2-1.5.170.ebuild:
+ Version bump.
*oauth2-1.5.169 (04 May 2011)
diff --git a/dev-python/oauth2/oauth2-1.5.170.ebuild b/dev-python/oauth2/oauth2-1.5.170.ebuild
new file mode 100644
index 000000000000..495aed400057
--- /dev/null
+++ b/dev-python/oauth2/oauth2-1.5.170.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauth2/oauth2-1.5.170.ebuild,v 1.1 2011/05/05 16:41:43 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Library for OAuth version 1.0"
+HOMEPAGE="http://pypi.python.org/pypi/oauth2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/httplib2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? (
+ dev-python/coverage
+ dev-python/mock
+ )"
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/tests"
+ }
+ python_execute_function -q delete_tests
+}