summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-18 07:50:19 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-18 07:50:19 +0000
commitf7e8fc02b613e21db0266cbf0a0d69b6fdd0905f (patch)
treebb6052fd80636ba931902db86cead5386486fd1d /dev-python/nose
parentupdate of cinder for = deps (changed to ~) and updated all packages I could t... (diff)
downloadgentoo-2-f7e8fc02b613e21db0266cbf0a0d69b6fdd0905f.tar.gz
gentoo-2-f7e8fc02b613e21db0266cbf0a0d69b6fdd0905f.tar.bz2
gentoo-2-f7e8fc02b613e21db0266cbf0a0d69b6fdd0905f.zip
Re-use distutils-r1_python_install_all.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog6
-rw-r--r--dev-python/nose/nose-1.3.0.ebuild11
-rw-r--r--dev-python/nose/nose-9999.ebuild11
3 files changed, 15 insertions, 13 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 54bcf815179b..55d1845849a9 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.118 2013/08/07 11:21:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.119 2013/08/18 07:50:19 mgorny Exp $
+
+ 18 Aug 2013; Michał Górny <mgorny@gentoo.org> nose-1.3.0.ebuild,
+ nose-9999.ebuild:
+ Re-use distutils-r1_python_install_all.
07 Aug 2013; Michał Górny <mgorny@gentoo.org> nose-1.1.2-r1.ebuild,
nose-1.2.1.ebuild, nose-1.2.1_p2012.ebuild, nose-9999.ebuild:
diff --git a/dev-python/nose/nose-1.3.0.ebuild b/dev-python/nose/nose-1.3.0.ebuild
index 680a19e483b9..adea9a2efd08 100644
--- a/dev-python/nose/nose-1.3.0.ebuild
+++ b/dev-python/nose/nose-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.3.0.ebuild,v 1.15 2013/08/03 09:45:39 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.3.0.ebuild,v 1.16 2013/08/18 07:50:19 mgorny Exp $
EAPI=5
@@ -78,11 +78,10 @@ python_install() {
}
python_install_all() {
+ local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+
if use doc; then
- dohtml -r -A txt doc/.build/html/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dohtml -r -A txt doc/.build/html/.
fi
}
diff --git a/dev-python/nose/nose-9999.ebuild b/dev-python/nose/nose-9999.ebuild
index d4b17f53c930..dc551390776b 100644
--- a/dev-python/nose/nose-9999.ebuild
+++ b/dev-python/nose/nose-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-9999.ebuild,v 1.4 2013/08/07 11:21:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-9999.ebuild,v 1.5 2013/08/18 07:50:19 mgorny Exp $
EAPI=5
@@ -87,11 +87,10 @@ python_install() {
}
python_install_all() {
+ local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+
if use doc; then
- dohtml -r -A txt doc/.build/html/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dohtml -r -A txt doc/.build/html/.
fi
}