summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-12-22 10:17:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-12-22 10:17:58 +0000
commitd90eda3ee8a3885be7f37adce617146064c5ec11 (patch)
tree329f7f5bb13b3068135e407b029e1f0a9c74a125 /dev-python/nltk
parentVersion bump. Removed old (diff)
downloadgentoo-2-d90eda3ee8a3885be7f37adce617146064c5ec11.tar.gz
gentoo-2-d90eda3ee8a3885be7f37adce617146064c5ec11.tar.bz2
gentoo-2-d90eda3ee8a3885be7f37adce617146064c5ec11.zip
Version bump and add optional numpy support. Thanks to Corentin LABBE. Bugs #532608 and 528320
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'dev-python/nltk')
-rw-r--r--dev-python/nltk/ChangeLog9
-rw-r--r--dev-python/nltk/metadata.xml3
-rw-r--r--dev-python/nltk/nltk-2.0.4.ebuild9
-rw-r--r--dev-python/nltk/nltk-3.0.0.ebuild26
4 files changed, 42 insertions, 5 deletions
diff --git a/dev-python/nltk/ChangeLog b/dev-python/nltk/ChangeLog
index 163e5fed5a87..ca6f832d27db 100644
--- a/dev-python/nltk/ChangeLog
+++ b/dev-python/nltk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/nltk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/ChangeLog,v 1.16 2014/04/02 15:14:13 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/ChangeLog,v 1.17 2014/12/22 10:17:58 hwoarang Exp $
+
+*nltk-3.0.0 (22 Dec 2014)
+
+ 22 Dec 2014; Markos Chandras <hwoarang@gentoo.org> +nltk-3.0.0.ebuild,
+ metadata.xml, nltk-2.0.4.ebuild:
+ Version bump and add optional numpy support. Thanks to Corentin LABBE. Bugs
+ #532608 and 528320
*nltk-2.0.4 (02 Apr 2014)
diff --git a/dev-python/nltk/metadata.xml b/dev-python/nltk/metadata.xml
index 4830f7b32dc4..56c7faa75e74 100644
--- a/dev-python/nltk/metadata.xml
+++ b/dev-python/nltk/metadata.xml
@@ -8,6 +8,9 @@
<description>Maintainer. Assign bugs to him</description>
</maintainer>
<herd>python</herd>
+ <use>
+ <flag name="numpy">Use numpy for the saved word tokenizer</flag>
+ </use>
<upstream>
<remote-id type="google-code">nltk</remote-id>
</upstream>
diff --git a/dev-python/nltk/nltk-2.0.4.ebuild b/dev-python/nltk/nltk-2.0.4.ebuild
index c6a30405f76e..cfb292eea2a5 100644
--- a/dev-python/nltk/nltk-2.0.4.ebuild
+++ b/dev-python/nltk/nltk-2.0.4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0.4.ebuild,v 1.1 2014/04/02 15:14:13 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0.4.ebuild,v 1.2 2014/12/22 10:17:58 hwoarang Exp $
EAPI="5"
-PYTHON_COMPAT=( python2_{6,7} )
-PYTHON_REQ_USE="tk(+),xml(+)"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="tk?,xml(+)"
inherit distutils-r1
@@ -16,9 +16,10 @@ HOMEPAGE="http://nltk.org/"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="numpy tk"
RDEPEND="${RDEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
diff --git a/dev-python/nltk/nltk-3.0.0.ebuild b/dev-python/nltk/nltk-3.0.0.ebuild
new file mode 100644
index 000000000000..40ccf7e776a8
--- /dev/null
+++ b/dev-python/nltk/nltk-3.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-3.0.0.ebuild,v 1.1 2014/12/22 10:17:58 hwoarang Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_4} )
+PYTHON_REQ_USE="tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://nltk.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="numpy tk"
+
+RDEPEND="${RDEPEND}
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"