summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-31 22:27:13 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-31 22:27:13 +0000
commitad84cc69b49e3ba53b34834e017d9d0513300f03 (patch)
treebca34b45d8987f463558037526f453742dc50835 /dev-python/minimock
parentUnbundled half of the libraries, the other half is missing, committed as unke... (diff)
downloadgentoo-2-ad84cc69b49e3ba53b34834e017d9d0513300f03.tar.gz
gentoo-2-ad84cc69b49e3ba53b34834e017d9d0513300f03.tar.bz2
gentoo-2-ad84cc69b49e3ba53b34834e017d9d0513300f03.zip
Revision bump, migrate to distutils-r1.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/minimock')
-rw-r--r--dev-python/minimock/ChangeLog7
-rw-r--r--dev-python/minimock/minimock-1.2.8-r1.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/minimock/ChangeLog b/dev-python/minimock/ChangeLog
index c493336a2f4d..ad639bec2d1a 100644
--- a/dev-python/minimock/ChangeLog
+++ b/dev-python/minimock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/minimock
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/minimock/ChangeLog,v 1.19 2013/05/20 17:24:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/minimock/ChangeLog,v 1.20 2013/05/31 22:27:13 radhermit Exp $
+
+*minimock-1.2.8-r1 (31 May 2013)
+
+ 31 May 2013; Tim Harder <radhermit@gentoo.org> +minimock-1.2.8-r1.ebuild:
+ Revision bump, migrate to distutils-r1.
20 May 2013; Agostino Sarubbo <ago@gentoo.org> minimock-1.2.8.ebuild:
Stable for arm, wrt bug #470452
diff --git a/dev-python/minimock/minimock-1.2.8-r1.ebuild b/dev-python/minimock/minimock-1.2.8-r1.ebuild
new file mode 100644
index 000000000000..6b9a25c4df7a
--- /dev/null
+++ b/dev-python/minimock/minimock-1.2.8-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/minimock/minimock-1.2.8-r1.ebuild,v 1.1 2013/05/31 22:27:13 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+MY_PN="MiniMock"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The simplest possible mock library"
+HOMEPAGE="http://pypi.python.org/pypi/MiniMock"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( docs/changelog.rst docs/index.rst )