summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-09 18:01:22 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-09 18:01:22 +0000
commit40be750a3a2caf76d2499b4037333d958a4af1e2 (patch)
tree1c67b52e68c981e6a41b99adb2fc977c59c03b27 /dev-python/mantissa
parentAdd die in pkg_pretend when attempting to build with gold (bug #450024), copi... (diff)
downloadgentoo-2-40be750a3a2caf76d2499b4037333d958a4af1e2.tar.gz
gentoo-2-40be750a3a2caf76d2499b4037333d958a4af1e2.tar.bz2
gentoo-2-40be750a3a2caf76d2499b4037333d958a4af1e2.zip
Migrate to twisted-r1.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/mantissa')
-rw-r--r--dev-python/mantissa/ChangeLog7
-rw-r--r--dev-python/mantissa/mantissa-0.7.0-r1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/mantissa/ChangeLog b/dev-python/mantissa/ChangeLog
index 813a52e84692..66461b5643c8 100644
--- a/dev-python/mantissa/ChangeLog
+++ b/dev-python/mantissa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mantissa
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.19 2013/08/03 09:45:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.20 2013/08/09 18:01:22 mgorny Exp $
+
+*mantissa-0.7.0-r1 (09 Aug 2013)
+
+ 09 Aug 2013; Michał Górny <mgorny@gentoo.org> +mantissa-0.7.0-r1.ebuild:
+ Migrate to twisted-r1.
03 Aug 2013; Michał Górny <mgorny@gentoo.org> mantissa-0.7.0.ebuild:
Move dev-python/twisted to dev-python/twisted-core.
diff --git a/dev-python/mantissa/mantissa-0.7.0-r1.ebuild b/dev-python/mantissa/mantissa-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..668d6b403a0d
--- /dev/null
+++ b/dev-python/mantissa/mantissa-0.7.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.7.0-r1.ebuild,v 1.1 2013/08/09 18:01:21 mgorny Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit twisted-r1
+
+DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodMantissa http://pypi.python.org/pypi/Mantissa"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/axiom-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/cssutils-0.9.10-r1[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/nevow-0.10.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-mail[${PYTHON_USEDEP}]
+ >=dev-python/vertex-0.3.0-r1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
+
+python_install() {
+ distutils-r1_python_install
+
+ # remove foreign caches we don't want to own
+ find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
+ # then our own one
+ touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ trial xmantissa || die "tests failed with ${EPYTHON}"
+}