summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-02-21 15:05:03 +0000
committerIan Delaney <idella4@gentoo.org>2013-02-21 15:05:03 +0000
commit9318229e5602b1413bc4c77f8bb53f2ea1b54c65 (patch)
tree4e5692beef54cd569bf6456ced69fb2a6c203ae1 /dev-python/logbook/logbook-0.4.1.ebuild
parentStable for ia64, wrt bug #458122 (diff)
downloadgentoo-2-9318229e5602b1413bc4c77f8bb53f2ea1b54c65.tar.gz
gentoo-2-9318229e5602b1413bc4c77f8bb53f2ea1b54c65.tar.bz2
gentoo-2-9318229e5602b1413bc4c77f8bb53f2ea1b54c65.zip
bump with required patch to pass testsuite; closes Bug 451248
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/logbook/logbook-0.4.1.ebuild')
-rw-r--r--dev-python/logbook/logbook-0.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/logbook/logbook-0.4.1.ebuild b/dev-python/logbook/logbook-0.4.1.ebuild
new file mode 100644
index 000000000000..5809a3534ea7
--- /dev/null
+++ b/dev-python/logbook/logbook-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.4.1.ebuild,v 1.1 2013/02/21 15:05:03 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1 eutils
+
+MY_PN=${PN/l/L}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS="CHANGES README"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-testspy3.patch
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test
+}