summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-06 07:46:46 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-06 07:46:46 +0000
commit17a3b385e06101b819c63adc844a5b17e1266418 (patch)
treec92c6bcba112b645df3b406b0808deb4bf529e32 /dev-python/llfuse
parentEAPI=5; add arm support patch from Torsten Kurbad (bug #448134) (diff)
downloadgentoo-2-17a3b385e06101b819c63adc844a5b17e1266418.tar.gz
gentoo-2-17a3b385e06101b819c63adc844a5b17e1266418.tar.bz2
gentoo-2-17a3b385e06101b819c63adc844a5b17e1266418.zip
Version bump. Migrate to distutils-r1.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/ChangeLog9
-rw-r--r--dev-python/llfuse/llfuse-0.38.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/llfuse/ChangeLog b/dev-python/llfuse/ChangeLog
index 12da1936daf7..e7164048fcb1 100644
--- a/dev-python/llfuse/ChangeLog
+++ b/dev-python/llfuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/llfuse
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/ChangeLog,v 1.8 2012/05/09 03:24:16 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/ChangeLog,v 1.9 2013/01/06 07:46:46 radhermit Exp $
+
+*llfuse-0.38 (06 Jan 2013)
+
+ 06 Jan 2013; Tim Harder <radhermit@gentoo.org> +llfuse-0.38.ebuild:
+ Version bump. Migrate to distutils-r1.
09 May 2012; Mike Gilbert <floppym@gentoo.org> llfuse-0.37.1.ebuild:
Set PYTHON_DEPEND.
diff --git a/dev-python/llfuse/llfuse-0.38.ebuild b/dev-python/llfuse/llfuse-0.38.ebuild
new file mode 100644
index 000000000000..39e2df0d00e9
--- /dev/null
+++ b/dev-python/llfuse/llfuse-0.38.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llfuse/llfuse-0.38.ebuild,v 1.1 2013/01/06 07:46:46 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="http://python-llfuse.googlecode.com/ http://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=sys-fs/fuse-2.8.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/html/*
+}