summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-06-14 15:41:08 +0000
committerMatthias Maier <tamiko@gentoo.org>2015-06-14 15:41:08 +0000
commit994cc47b1892741b6f630c8a8bf1ea4ab8205915 (patch)
treeed268e033fb3eef24d91fd50250a20100f443883 /dev-python/libvirt-python
parentversion bump, bug #550992, thanks to Thomas Stein for reporting (diff)
downloadgentoo-2-994cc47b1892741b6f630c8a8bf1ea4ab8205915.tar.gz
gentoo-2-994cc47b1892741b6f630c8a8bf1ea4ab8205915.tar.bz2
gentoo-2-994cc47b1892741b6f630c8a8bf1ea4ab8205915.zip
version bump, bug #550992, thanks to Thomas Stein for reporting
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/ChangeLog7
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.2.16.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/libvirt-python/ChangeLog b/dev-python/libvirt-python/ChangeLog
index 04c2fc4ba2d7..2f06fb2079b6 100644
--- a/dev-python/libvirt-python/ChangeLog
+++ b/dev-python/libvirt-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libvirt-python
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v 1.37 2015/05/25 01:57:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v 1.38 2015/06/14 15:41:08 tamiko Exp $
+
+*libvirt-python-1.2.16 (14 Jun 2015)
+
+ 14 Jun 2015; Matthias Maier <tamiko@gentoo.org> +libvirt-python-1.2.16.ebuild:
+ version bump, bug #550992, thanks to Thomas Stein for reporting
25 May 2015; Patrick Lauer <patrick@gentoo.org> -libvirt-python-1.2.11.ebuild,
-libvirt-python-1.2.13.ebuild:
diff --git a/dev-python/libvirt-python/libvirt-python-1.2.16.ebuild b/dev-python/libvirt-python/libvirt-python-1.2.16.ebuild
new file mode 100644
index 000000000000..18dfb5ff2500
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-1.2.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/libvirt-python-1.2.16.ebuild,v 1.1 2015/06/14 15:41:08 tamiko Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}