summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-20 00:09:47 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-20 00:09:47 +0000
commit3f579f8970df610890d6f5c96abbf035ab7db1c7 (patch)
treea5cba6ec606049b188ad1ee3ae731cb5bb57a606 /dev-python/kiwi
parentVersion bump. (diff)
downloadgentoo-2-3f579f8970df610890d6f5c96abbf035ab7db1c7.tar.gz
gentoo-2-3f579f8970df610890d6f5c96abbf035ab7db1c7.tar.bz2
gentoo-2-3f579f8970df610890d6f5c96abbf035ab7db1c7.zip
Version bump for #390109. Thanks to Ian Delaney for pointing out the test suite. Drop ppc and ppc64 keywords due to new deps.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/kiwi')
-rw-r--r--dev-python/kiwi/ChangeLog8
-rw-r--r--dev-python/kiwi/kiwi-1.9.34.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index c0e233673edc..bd0035d7e14a 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/kiwi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.15 2012/02/24 08:02:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.16 2012/05/20 00:09:47 floppym Exp $
+
+*kiwi-1.9.34 (20 May 2012)
+
+ 20 May 2012; Mike Gilbert <floppym@gentoo.org> +kiwi-1.9.34.ebuild:
+ Version bump for #390109. Thanks to Ian Delaney for pointing out the test
+ suite. Drop ppc and ppc64 keywords due to new deps.
24 Feb 2012; Patrick Lauer <patrick@gentoo.org> kiwi-1.9.26.ebuild:
Restricting pypy
diff --git a/dev-python/kiwi/kiwi-1.9.34.ebuild b/dev-python/kiwi/kiwi-1.9.34.ebuild
new file mode 100644
index 000000000000..5d3c4e7ddd83
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.34.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.34.ebuild,v 1.1 2012/05/20 00:09:46 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython *-pypy-*"
+
+inherit distutils versionator virtualx
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/
+ https://launchpad.net/kiwi
+ http://pypi.python.org/pypi/kiwi-gtk"
+MY_PN="${PN}-gtk"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="dev-python/pygtk"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pep8
+ dev-python/pyflakes
+ dev-python/twisted
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ # Tarballs are missing files.
+ # https://code.launchpad.net/~floppym/kiwi/testfiles/+merge/106505
+ rm tests/test_ui.py tests/test_Delegate.py
+
+ testing() {
+ "$(PYTHON)" tests/run_all_tests.py
+ }
+ VIRTUALX_COMMAND=python_execute_function virtualmake testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}