summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-07 00:03:34 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-07 00:03:34 +0000
commit098c0da0535b2b572bd424ef6e49174838f9ce97 (patch)
treeee0c4fc2934e71a31936ce9dd6c9e5a6b16af5f5 /dev-python/keyring
parentMark s390 profiles stable. (diff)
downloadgentoo-2-098c0da0535b2b572bd424ef6e49174838f9ce97.tar.gz
gentoo-2-098c0da0535b2b572bd424ef6e49174838f9ce97.tar.bz2
gentoo-2-098c0da0535b2b572bd424ef6e49174838f9ce97.zip
Clean up the ebuild. Disable semi-interactive tests. Add Python team as a co-maintainer.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/ChangeLog7
-rw-r--r--dev-python/keyring/keyring-1.0.ebuild38
-rw-r--r--dev-python/keyring/metadata.xml21
3 files changed, 38 insertions, 28 deletions
diff --git a/dev-python/keyring/ChangeLog b/dev-python/keyring/ChangeLog
index 2fe1c2dd5b83..c5d1be9680df 100644
--- a/dev-python/keyring/ChangeLog
+++ b/dev-python/keyring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/keyring
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.4 2013/01/06 19:36:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.5 2013/01/07 00:03:34 mgorny Exp $
+
+ 07 Jan 2013; Michał Górny <mgorny@gentoo.org> keyring-1.0.ebuild,
+ metadata.xml:
+ Clean up the ebuild. Disable semi-interactive tests. Add Python team as a co-
+ maintainer.
06 Jan 2013; Michał Górny <mgorny@gentoo.org> keyring-1.0.ebuild:
Use virtual/python-unittest2.
diff --git a/dev-python/keyring/keyring-1.0.ebuild b/dev-python/keyring/keyring-1.0.ebuild
index 0fd3cb2da428..2c00193843bb 100644
--- a/dev-python/keyring/keyring-1.0.ebuild
+++ b/dev-python/keyring/keyring-1.0.ebuild
@@ -1,33 +1,37 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-1.0.ebuild,v 1.4 2013/01/06 19:36:42 mgorny Exp $
-# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-1.0.ebuild,v 1.5 2013/01/07 00:03:34 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
-inherit distutils-r1 eutils
+inherit distutils-r1
-MY_PN=${PN#python-}
-S="${WORKDIR}/${MY_PN}-${PV}"
-DESCRIPTION="Provides a easy way to access the system keyring service from
-python."
+DESCRIPTION="Provides access to the system keyring service"
HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
-SRC_URI="mirror://pypi/k/${MY_PN}/${MY_PN}-${PV}.zip"
+SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
+
LICENSE="PSF-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test"
+
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest
- dev-python/pytest-runner
- virtual/python-unittest2[${PYTHON_USEDEP}] )"
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
RDEPEND=""
-PATCHES=( "${FILESDIR}/setup-1.0.patch" )
+
+PATCHES=(
+ "${FILESDIR}/setup-1.0.patch"
+)
python_test() {
- "${PYTHON}" keyring/tests/test_util.py || die
- "${PYTHON}" keyring/tests/test_backend.py || die
- "${PYTHON}" keyring/tests/test_core.py || die
- "${PYTHON}" keyring/tests/test_cli.py || die
+ # test_backend.py and test_core.py access keyring backends
+ # which may spawn password prompts and do other damage.
+
+ # XXX: leave out the harmless tests (dummy backends?)
+
+ for t in test_{cli,util}.py; do
+ "${PYTHON}" "${BUILD_DIR}"/lib/${PN}/tests/${t} \
+ || die "${t} fails with ${EPYTHON}"
+ done
}
diff --git a/dev-python/keyring/metadata.xml b/dev-python/keyring/metadata.xml
index a6e19e94b17a..9baa9a2364bb 100644
--- a/dev-python/keyring/metadata.xml
+++ b/dev-python/keyring/metadata.xml
@@ -1,11 +1,12 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer>
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <longdescription lang="en">
- Provides a easy way to access the system keyring service from python.
- </longdescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Provides a easy way to access the system keyring service from python.
+ </longdescription>
</pkgmetadata>