summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-08-16 16:12:15 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-08-16 16:12:15 +0000
commitc7ec569c7b0dc0bd46ae0fdf6356a79b911aacb0 (patch)
tree6124e0e7983e989135b51906b5da7808d0cfe010 /dev-python/kaa-imlib2
parentRemove stkn from metadata.xml (#27693) (diff)
downloadgentoo-2-c7ec569c7b0dc0bd46ae0fdf6356a79b911aacb0.tar.gz
gentoo-2-c7ec569c7b0dc0bd46ae0fdf6356a79b911aacb0.tar.bz2
gentoo-2-c7ec569c7b0dc0bd46ae0fdf6356a79b911aacb0.zip
Do not link against libpng, bug #211013
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'dev-python/kaa-imlib2')
-rw-r--r--dev-python/kaa-imlib2/ChangeLog8
-rw-r--r--dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch11
-rw-r--r--dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild31
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/kaa-imlib2/ChangeLog b/dev-python/kaa-imlib2/ChangeLog
index 88b5565fcd4b..536c4c728b8e 100644
--- a/dev-python/kaa-imlib2/ChangeLog
+++ b/dev-python/kaa-imlib2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/kaa-imlib2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/ChangeLog,v 1.9 2008/05/01 09:26:12 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/ChangeLog,v 1.10 2008/08/16 16:12:14 rbu Exp $
+
+*kaa-imlib2-0.2.3-r1 (16 Aug 2008)
+
+ 16 Aug 2008; Robert Buchholz <rbu@gentoo.org>
+ +files/kaa-imlib2-remove-png-dep.patch, +kaa-imlib2-0.2.3-r1.ebuild:
+ Do not link against libpng, bug #211013
01 May 2008; Tobias Scherbaum <dertobi123@gentoo.org>
kaa-imlib2-0.2.3.ebuild:
diff --git a/dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch b/dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch
new file mode 100644
index 000000000000..0db6fefa9ca8
--- /dev/null
+++ b/dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch
@@ -0,0 +1,11 @@
+--- setup.py.old 2008-07-12 01:43:30.700296071 +0200
++++ setup.py 2008-07-12 01:43:57.441547566 +0200
+@@ -39,7 +39,7 @@
+ sys.exit(1)
+
+ files = [ 'src/imlib2.c', 'src/image.c', 'src/font.c', 'src/rawformats.c' ]
+-libraries = [ 'png']
++libraries = []
+ if not os.uname()[0] in ('FreeBSD', 'Darwin'):
+ libraries.append('rt')
+ imlib2so = Extension('kaa.imlib2._Imlib2module', files,
diff --git a/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..2b01208d2b2d
--- /dev/null
+++ b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild,v 1.1 2008/08/16 16:12:14 rbu Exp $
+
+inherit python eutils distutils
+
+DESCRIPTION="Imlib2 wrapper for Python."
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/kaa-base-0.3.0
+ dev-libs/libxml2
+ media-libs/imlib2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxml2 python; then
+ eerror "dev-libs/libxml2 must be built with the 'python' USE flag"
+ die "Recompile dev-libs/libxml2 with the 'python' USE flag enabled"
+ fi
+}
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}/kaa-imlib2-remove-png-dep.patch"
+}