summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-14 07:44:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-14 07:44:03 +0000
commitf12524cbb5399b2ea5c434782c328c42d16cbbd1 (patch)
tree8e366b5790be8787fd896edad38888885be98058 /dev-python/jsonpatch
parentBump (diff)
downloadgentoo-2-f12524cbb5399b2ea5c434782c328c42d16cbbd1.tar.gz
gentoo-2-f12524cbb5399b2ea5c434782c328c42d16cbbd1.tar.bz2
gentoo-2-f12524cbb5399b2ea5c434782c328c42d16cbbd1.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/ChangeLog7
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.7.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/jsonpatch/ChangeLog b/dev-python/jsonpatch/ChangeLog
index 59a39150bf50..4c74bda4aef9 100644
--- a/dev-python/jsonpatch/ChangeLog
+++ b/dev-python/jsonpatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/jsonpatch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpatch/ChangeLog,v 1.5 2014/04/03 06:48:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpatch/ChangeLog,v 1.6 2014/07/14 07:44:03 patrick Exp $
+
+*jsonpatch-1.7 (14 Jul 2014)
+
+ 14 Jul 2014; Patrick Lauer <patrick@gentoo.org> +jsonpatch-1.7.ebuild:
+ Bump
*jsonpatch-1.5 (03 Apr 2014)
diff --git a/dev-python/jsonpatch/jsonpatch-1.7.ebuild b/dev-python/jsonpatch/jsonpatch-1.7.ebuild
new file mode 100644
index 000000000000..a9bf2267be94
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpatch/jsonpatch-1.7.ebuild,v 1.1 2014/07/14 07:44:03 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+ http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/jsonpointer-1.3[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}