summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-23 01:44:48 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-23 01:44:48 +0000
commitaa735a6561180fabdd92f1e8da2d7fc1b8cdf334 (patch)
treeb34dbe7feef6222c4afdd728f5567f1f76c22aeb /dev-python/jinja
parentSimplify docs build. (diff)
downloadgentoo-2-aa735a6561180fabdd92f1e8da2d7fc1b8cdf334.tar.gz
gentoo-2-aa735a6561180fabdd92f1e8da2d7fc1b8cdf334.tar.bz2
gentoo-2-aa735a6561180fabdd92f1e8da2d7fc1b8cdf334.zip
Fix error building docs, bug 470856.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/jinja')
-rw-r--r--dev-python/jinja/ChangeLog6
-rw-r--r--dev-python/jinja/files/jinja-2.7-docs.patch53
-rw-r--r--dev-python/jinja/jinja-2.7.ebuild3
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-python/jinja/ChangeLog b/dev-python/jinja/ChangeLog
index 313a52993439..7c459eb4805c 100644
--- a/dev-python/jinja/ChangeLog
+++ b/dev-python/jinja/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/jinja
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/ChangeLog,v 1.70 2013/05/23 01:34:34 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/ChangeLog,v 1.71 2013/05/23 01:44:48 floppym Exp $
+
+ 23 May 2013; Mike Gilbert <floppym@gentoo.org> +files/jinja-2.7-docs.patch,
+ jinja-2.7.ebuild:
+ Fix error building docs, bug 470856.
23 May 2013; Mike Gilbert <floppym@gentoo.org> jinja-2.7.ebuild:
Simplify docs build.
diff --git a/dev-python/jinja/files/jinja-2.7-docs.patch b/dev-python/jinja/files/jinja-2.7-docs.patch
new file mode 100644
index 000000000000..d543f54d6cd7
--- /dev/null
+++ b/dev-python/jinja/files/jinja-2.7-docs.patch
@@ -0,0 +1,53 @@
+From da94a8b504d981cb5f877219811d169823a2095e Mon Sep 17 00:00:00 2001
+From: Armin Ronacher <armin.ronacher@active-4.com>
+Date: Mon, 20 May 2013 14:06:59 +0100
+Subject: [PATCH] Fixed docs not building
+
+---
+ docs/faq.rst | 2 +-
+ docs/jinjaext.py | 2 +-
+ docs/templates.rst | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/docs/faq.rst b/docs/faq.rst
+index 4db5079..00a4d0d 100644
+--- a/docs/faq.rst
++++ b/docs/faq.rst
+@@ -157,7 +157,7 @@ Python 2.3 support you either have to use `Jinja 1`_ or other templating
+ engines that still support 2.3.
+
+ My Macros are overridden by something
+-------------------------------------
++-------------------------------------
+
+ In some situations the Jinja scoping appears arbitrary:
+
+diff --git a/docs/jinjaext.py b/docs/jinjaext.py
+index 8395a55..3c217f8 100644
+--- a/docs/jinjaext.py
++++ b/docs/jinjaext.py
+@@ -23,7 +23,7 @@
+ from pygments.token import Keyword, Name, Comment, String, Error, \
+ Number, Operator, Generic
+ from jinja2 import Environment, FileSystemLoader
+-from jinja2.utils import next
++from jinja2._compat import next
+
+
+ def parse_rst(state, content_offset, doc):
+diff --git a/docs/templates.rst b/docs/templates.rst
+index e0a19fa..4a6a379 100644
+--- a/docs/templates.rst
++++ b/docs/templates.rst
+@@ -579,7 +579,7 @@ Inside of a for-loop block you can access some special variables:
+ | `loop.depth` | Indicates how deep in deep in a recursive loop |
+ | | the rendering currently is. Starts at level 1 |
+ +-----------------------+---------------------------------------------------+
+-| `loop.depth0 | Indicates how deep in deep in a recursive loop |
++| `loop.depth0` | Indicates how deep in deep in a recursive loop |
+ | | the rendering currently is. Starts at level 0 |
+ +-----------------------+---------------------------------------------------+
+
+--
+1.8.1.6
+
diff --git a/dev-python/jinja/jinja-2.7.ebuild b/dev-python/jinja/jinja-2.7.ebuild
index f4a026ba2000..e97a07f7ba11 100644
--- a/dev-python/jinja/jinja-2.7.ebuild
+++ b/dev-python/jinja/jinja-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.7.ebuild,v 1.2 2013/05/23 01:34:34 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.7.ebuild,v 1.3 2013/05/23 01:44:48 floppym Exp $
EAPI=5
@@ -28,6 +28,7 @@ DEPEND="${RDEPEND}
# XXX: handle Babel better?
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}/jinja-2.7-docs.patch" )
wrap_opts() {
local mydistutilsargs=()