summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-09-26 17:59:01 +0000
committerMike Gilbert <floppym@gentoo.org>2013-09-26 17:59:01 +0000
commitcb75133517967100a6bf814073ed1bb261ef9035 (patch)
treea1ac3cdb75be8ed2e3ede60e61f3137f27acfc3e /dev-python/ipython/ipython-1.0.0.ebuild
parentremoved old (bug #478608) (diff)
downloadgentoo-2-cb75133517967100a6bf814073ed1bb261ef9035.tar.gz
gentoo-2-cb75133517967100a6bf814073ed1bb261ef9035.tar.bz2
gentoo-2-cb75133517967100a6bf814073ed1bb261ef9035.zip
Add patch to ensure consistent setuptools behavior with python2.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/ipython/ipython-1.0.0.ebuild')
-rw-r--r--dev-python/ipython/ipython-1.0.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/ipython/ipython-1.0.0.ebuild b/dev-python/ipython/ipython-1.0.0.ebuild
index 2fbd88cbc472..3fcba654a7b3 100644
--- a/dev-python/ipython/ipython-1.0.0.ebuild
+++ b/dev-python/ipython/ipython-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-1.0.0.ebuild,v 1.11 2013/09/15 16:00:19 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-1.0.0.ebuild,v 1.12 2013/09/26 17:59:01 floppym Exp $
EAPI=5
@@ -62,6 +62,10 @@ REQUIRED_USE="
octave? ( ${PY2_REQUSE} )
wxwidgets? ( ${PY2_REQUSE} )"
+PATCHES=(
+ "${FILESDIR}/ipython-1.0.0-setuptools.patch"
+)
+
python_prepare_all() {
# fix for gentoo python scripts
sed -i \