summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 23:06:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 23:06:27 +0000
commit849ed8ee4b6132512a1616c672a5868da9c418e9 (patch)
treebc124b8cccd1362766f926e202173137d400d5a5 /dev-python/imaging/files
parentUpdate EAPI. Fix dependencies. Don't inherit unused eclass. (diff)
downloadgentoo-2-849ed8ee4b6132512a1616c672a5868da9c418e9.tar.gz
gentoo-2-849ed8ee4b6132512a1616c672a5868da9c418e9.tar.bz2
gentoo-2-849ed8ee4b6132512a1616c672a5868da9c418e9.zip
Delete older ebuild.
(Portage version: 2.2.0_alpha2_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/imaging/files')
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-giftrans.patch14
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-missing-math.patch20
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-no-xv.patch13
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-sane.patch13
-rw-r--r--dev-python/imaging/files/imaging-1.1.6-tiffendian.patch40
5 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/imaging/files/imaging-1.1.6-giftrans.patch b/dev-python/imaging/files/imaging-1.1.6-giftrans.patch
deleted file mode 100644
index 1a109d28eee0..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-giftrans.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- Imaging-1.1.6.orig/PIL/GifImagePlugin.py 2006-12-03 11:37:15.000000000 +0000
-+++ Imaging-1.1.6/PIL/GifImagePlugin.py 2008-10-02 14:51:43.000000000 +0100
-@@ -352,6 +352,11 @@
- for i in range(maxcolor):
- s.append(chr(i) * 3)
-
-+ if im.info.has_key('transparency'):
-+ transparentIndex = im.info['transparency']
-+ s.append('!' + chr(0xf9) + chr(4) + chr(1) + chr(0) + chr(0) +
-+ chr(transparentIndex) + chr(0))
-+
- return s
-
- def getdata(im, offset = (0, 0), **params):
diff --git a/dev-python/imaging/files/imaging-1.1.6-missing-math.patch b/dev-python/imaging/files/imaging-1.1.6-missing-math.patch
deleted file mode 100644
index f4d6167eeccc..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-missing-math.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- setup.py.old 2009-07-03 11:34:59.141671252 +0200
-+++ setup.py 2009-07-03 11:51:54.415666711 +0200
-@@ -281,6 +281,8 @@ class pil_build_ext(build_ext):
- if struct.unpack("h", "\0\1")[0] == 1:
- defs.append(("WORDS_BIGENDIAN", None))
-
-+ libs.append("m")
-+
- exts = [(Extension(
- "_imaging", files, libraries=libs, define_macros=defs
- ))]
-@@ -332,7 +334,7 @@ class pil_build_ext(build_ext):
- ))
-
- if os.path.isfile("_imagingmath.c"):
-- exts.append(Extension("_imagingmath", ["_imagingmath.c"]))
-+ exts.append(Extension("_imagingmath", ["_imagingmath.c"], libraries=["m"]))
-
- self.extensions[:] = exts
-
diff --git a/dev-python/imaging/files/imaging-1.1.6-no-xv.patch b/dev-python/imaging/files/imaging-1.1.6-no-xv.patch
deleted file mode 100644
index fef002193fd0..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-no-xv.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- PIL/Image.py.orig 2009-03-20 18:19:52.184274983 +0000
-+++ PIL/Image.py 2009-03-20 18:20:48.605088504 +0000
-@@ -2065,9 +2065,7 @@
- else:
- format = None
- if not command:
-- command = "xv"
-- if title:
-- command = command + " -name \"%s\"" % title
-+ command = "xdg-open"
-
- if image.mode == "I;16":
- # @PIL88 @PIL101
diff --git a/dev-python/imaging/files/imaging-1.1.6-sane.patch b/dev-python/imaging/files/imaging-1.1.6-sane.patch
deleted file mode 100644
index 4970e50033a4..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-sane.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Imaging-1.1.6/Sane/_sane.c.orig 2006-12-03 13:12:22.000000000 +0100
-+++ Imaging-1.1.6/Sane/_sane.c 2009-02-28 11:41:19.000000000 +0200
-@@ -1152,8 +1152,8 @@
- static PyObject *
- PySane_get_devices(PyObject *self, PyObject *args)
- {
-- SANE_Device **devlist;
-- SANE_Device *dev;
-+ const SANE_Device **devlist;
-+ const SANE_Device *dev;
- SANE_Status st;
- PyObject *list;
- int local_only, i;
diff --git a/dev-python/imaging/files/imaging-1.1.6-tiffendian.patch b/dev-python/imaging/files/imaging-1.1.6-tiffendian.patch
deleted file mode 100644
index 441725a7fe12..000000000000
--- a/dev-python/imaging/files/imaging-1.1.6-tiffendian.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- Imaging-1.1.6/PIL/Image.py.orig 2009-07-15 07:44:06.210499375 -0700
-+++ Imaging-1.1.6/PIL/Image.py 2009-07-15 07:47:38.546498713 -0700
-@@ -197,6 +197,7 @@
- "1": ('|b1', None),
- "L": ('|u1', None),
- "I": ('%si4' % _ENDIAN, None), # FIXME: is this correct?
-+ "I;16": ('%si2' % _ENDIAN, None),
- "F": ('%sf4' % _ENDIAN, None), # FIXME: is this correct?
- "P": ('|u1', None),
- "RGB": ('|u1', 3),
---- Imaging-1.1.6/PIL/TiffImagePlugin.py.orig 2009-07-15 07:50:27.723535040 -0700
-+++ Imaging-1.1.6/PIL/TiffImagePlugin.py 2009-07-15 07:50:40.490496978 -0700
-@@ -577,10 +577,16 @@
- xdpi = getscalar(X_RESOLUTION, (1, 1))
- ydpi = getscalar(Y_RESOLUTION, (1, 1))
-
-- if xdpi and ydpi and getscalar(RESOLUTION_UNIT, 1) == 1:
-+ if xdpi and ydpi:
- xdpi = xdpi[0] / (xdpi[1] or 1)
- ydpi = ydpi[0] / (ydpi[1] or 1)
-- self.info["dpi"] = xdpi, ydpi
-+ unit = getscalar(RESOLUTION_UNIT, 1)
-+ if unit == 1:
-+ self.info["aspect"] = xdpi, ydpi
-+ elif unit == 2:
-+ self.info["dpi"] = xdpi, ydpi
-+ elif unit == 3:
-+ self.info["dpi"] = (xdpi*.39370079, ydpi*.39370079)
-
- # build tile descriptors
- x = y = l = 0
-@@ -718,7 +724,7 @@
-
- dpi = im.encoderinfo.get("dpi")
- if dpi:
-- ifd[RESOLUTION_UNIT] = 1
-+ ifd[RESOLUTION_UNIT] = 2
- ifd[X_RESOLUTION] = _cvt_res(dpi[0])
- ifd[Y_RESOLUTION] = _cvt_res(dpi[1])
-