summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-11 11:50:47 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-11 11:50:47 +0000
commit13de89bb61f4b0394a716589c80807260cfeac0f (patch)
tree5d83f62923bb33fa4ba772204342e2f1c23c8b86 /dev-python/hcs-utils/hcs-utils-1.5.ebuild
parentStable for amd64 wrt bug #505340 (diff)
downloadgentoo-2-13de89bb61f4b0394a716589c80807260cfeac0f.tar.gz
gentoo-2-13de89bb61f4b0394a716589c80807260cfeac0f.tar.bz2
gentoo-2-13de89bb61f4b0394a716589c80807260cfeac0f.zip
bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hcs-utils/hcs-utils-1.5.ebuild')
-rw-r--r--dev-python/hcs-utils/hcs-utils-1.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hcs-utils/hcs-utils-1.5.ebuild b/dev-python/hcs-utils/hcs-utils-1.5.ebuild
new file mode 100644
index 000000000000..87aaa4514431
--- /dev/null
+++ b/dev-python/hcs-utils/hcs-utils-1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hcs-utils/hcs-utils-1.5.ebuild,v 1.1 2014/04/11 11:50:47 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="A library containing some useful snippets"
+HOMEPAGE="http://pypi.python.org/pypi/hcs_utils"
+SRC_URI="mirror://pypi/h/${PN/-/_}/${MY_P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P/-/_}"
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null
+ py.test --doctest-modules hcs_utils || die "Tests failed"
+}