summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2015-01-14 22:01:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2015-01-14 22:01:38 +0000
commit9d838c5027bfc9b5578f75b227b1a02d10d0a67b (patch)
tree6da3b77454358ce1d1126d7c3745b0df25e6caea /dev-python/h5py
parentcleanup pic use flag on hardened amd64 (diff)
downloadgentoo-2-9d838c5027bfc9b5578f75b227b1a02d10d0a67b.tar.gz
gentoo-2-9d838c5027bfc9b5578f75b227b1a02d10d0a67b.tar.bz2
gentoo-2-9d838c5027bfc9b5578f75b227b1a02d10d0a67b.zip
Version bump, drop old
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/ChangeLog10
-rw-r--r--dev-python/h5py/h5py-2.2.1.ebuild44
-rw-r--r--dev-python/h5py/h5py-2.4.0.ebuild (renamed from dev-python/h5py/h5py-2.2.1-r1.ebuild)25
3 files changed, 20 insertions, 59 deletions
diff --git a/dev-python/h5py/ChangeLog b/dev-python/h5py/ChangeLog
index ef16186770c4..e54c15019bcc 100644
--- a/dev-python/h5py/ChangeLog
+++ b/dev-python/h5py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/h5py
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/ChangeLog,v 1.31 2014/08/11 07:07:13 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/ChangeLog,v 1.32 2015/01/14 22:01:38 xarthisius Exp $
+
+*h5py-2.4.0 (14 Jan 2015)
+
+ 14 Jan 2015; <xarth@gentoo.org> +h5py-2.4.0.ebuild, -h5py-2.2.1-r1.ebuild,
+ -h5py-2.2.1.ebuild:
+ Version bump, drop old
11 Aug 2014; Justin Lecher <jlec@gentoo.org> h5py-2.3.1.ebuild:
Add python3.4 support
diff --git a/dev-python/h5py/h5py-2.2.1.ebuild b/dev-python/h5py/h5py-2.2.1.ebuild
deleted file mode 100644
index 42a697682e3e..000000000000
--- a/dev-python/h5py/h5py-2.2.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.2.1.ebuild,v 1.2 2014/07/06 12:41:32 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple Python interface to HDF5 files"
-HOMEPAGE="http://www.h5py.org/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test examples"
-
-RDEPEND="
- sci-libs/hdf5:=
- dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- append-cflags -fno-strict-aliasing
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib/ && nosetests ./${PN}/lowtest || die
-}
-
-python_install_all() {
- DOCS=( README.rst ANN.rst )
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/h5py/h5py-2.2.1-r1.ebuild b/dev-python/h5py/h5py-2.4.0.ebuild
index af46a2f6ef2c..d674d3a933db 100644
--- a/dev-python/h5py/h5py-2.2.1-r1.ebuild
+++ b/dev-python/h5py/h5py-2.4.0.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.2.1-r1.ebuild,v 1.3 2014/07/06 12:41:32 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.4.0.ebuild,v 1.1 2015/01/14 22:01:38 xarthisius Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit distutils-r1 flag-o-matic
DESCRIPTION="Simple Python interface to HDF5 files"
HOMEPAGE="http://www.h5py.org/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test examples mpi"
RDEPEND="
- <sci-libs/hdf5-1.8.13
+ sci-libs/hdf5:=[mpi=]
dev-python/numpy[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -26,20 +26,19 @@ DEPEND="${RDEPEND}
mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
DISTUTILS_NO_PARALLEL_BUILD=1
-# Testsuite is written for a non mpi build
-REQUIRED_USE="test? ( !mpi )"
+pkg_setup() {
+ if use mpi ; then
+ export CC=mpicc
+ fi
+}
python_prepare_all() {
append-cflags -fno-strict-aliasing
distutils-r1_python_prepare_all
}
-python_compile() {
- if use mpi;then
- distutils-r1_python_compile --mpi=yes
- else
- distutils-r1_python_compile
- fi
+python_configure() {
+ esetup.py configure $(usex mpi --mpi '')
}
python_test() {