summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-09-04 17:22:42 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-09-04 17:22:42 +0000
commit70239c79285b2e831757778e1c76ee8b3fd10efb (patch)
tree2ad9be012d5c9b44118f55d2f22ce2816af6ddd5 /dev-python/h5py
parentPunt todo-list wrt bug 483626 (diff)
downloadgentoo-2-70239c79285b2e831757778e1c76ee8b3fd10efb.tar.gz
gentoo-2-70239c79285b2e831757778e1c76ee8b3fd10efb.tar.bz2
gentoo-2-70239c79285b2e831757778e1c76ee8b3fd10efb.zip
Version bump, add missing dependency on cython, drop old
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/ChangeLog9
-rw-r--r--dev-python/h5py/files/h5py-2.1-ucode.patch23
-rw-r--r--dev-python/h5py/h5py-2.1.2.ebuild29
-rw-r--r--dev-python/h5py/h5py-2.1.3.ebuild3
-rw-r--r--dev-python/h5py/h5py-2.2.0.ebuild (renamed from dev-python/h5py/h5py-2.1.2-r1.ebuild)14
5 files changed, 17 insertions, 61 deletions
diff --git a/dev-python/h5py/ChangeLog b/dev-python/h5py/ChangeLog
index 47ec1d2f4128..e08f389b1b7c 100644
--- a/dev-python/h5py/ChangeLog
+++ b/dev-python/h5py/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/h5py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/ChangeLog,v 1.19 2013/05/22 06:21:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/ChangeLog,v 1.20 2013/09/04 17:22:41 xarthisius Exp $
+
+*h5py-2.2.0 (04 Sep 2013)
+
+ 04 Sep 2013; Kacper Kowalik <xarthisius@gentoo.org> +h5py-2.2.0.ebuild,
+ -files/h5py-2.1-ucode.patch, -h5py-2.1.2-r1.ebuild, -h5py-2.1.2.ebuild,
+ h5py-2.1.3.ebuild:
+ Version bump, add missing dependency on cython, drop old
22 May 2013; Patrick Lauer <patrick@gentoo.org> h5py-2.1.3.ebuild:
Adding python-3.3 to python_targets
diff --git a/dev-python/h5py/files/h5py-2.1-ucode.patch b/dev-python/h5py/files/h5py-2.1-ucode.patch
deleted file mode 100644
index 5bc1a2f620f4..000000000000
--- a/dev-python/h5py/files/h5py-2.1-ucode.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-See https://github.com/h5py/h5py/issues/263
-diff -ur h5py-2.1.2.orig/h5py/_hl/tests/test_base.py h5py-2.1.2/h5py/_hl/tests/test_base.py
---- h5py/_hl/tests/test_base.py 2013-02-07 23:40:26.000000000 +0800
-+++ h5py/_hl/tests/test_base.py 2013-03-07 16:35:25.774142098 +0800
-@@ -62,6 +62,7 @@
- typ = self.f['type']
- self._check_type(typ)
-
-+ @unittest.skipUnless(sys.getfilesystemencoding() == 'UTF-8', "only passes for locale utf-8")
- def test_file(self):
- """ File object repr() with unicode """
- fname = tempfile.mktemp(self.USTRING+u'.hdf5')
-diff -ur h5py-2.1.2.orig/h5py/_hl/tests/test_file.py h5py-2.1.2/h5py/_hl/tests/test_file.py
---- h5py/_hl/tests/test_file.py 2013-02-07 23:40:26.000000000 +0800
-+++ h5py/_hl/tests/test_file.py 2013-03-07 16:34:59.006143430 +0800
-@@ -323,6 +323,7 @@
- self.assertTrue(fid)
- self.assertTrue(not fid)
-
-+@unittest.skipUnless(sys.getfilesystemencoding() == 'UTF-8', "only passes for locale utf-8")
- class TestUnicode(TestCase):
-
- """
diff --git a/dev-python/h5py/h5py-2.1.2.ebuild b/dev-python/h5py/h5py-2.1.2.ebuild
deleted file mode 100644
index e06fa0dc393b..000000000000
--- a/dev-python/h5py/h5py-2.1.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.1.2.ebuild,v 1.2 2013/02/28 10:06:41 xarthisius Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="A simple Python interface to HDF5 files"
-HOMEPAGE="http://h5py.alfven.org/ http://code.google.com/p/h5py/ http://pypi.python.org/pypi/h5py"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- sci-libs/hdf5:=
- dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- append-cflags -fno-strict-aliasing
-}
diff --git a/dev-python/h5py/h5py-2.1.3.ebuild b/dev-python/h5py/h5py-2.1.3.ebuild
index 35582f2d0e01..ce956164a495 100644
--- a/dev-python/h5py/h5py-2.1.3.ebuild
+++ b/dev-python/h5py/h5py-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.1.3.ebuild,v 1.2 2013/05/22 06:21:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.1.3.ebuild,v 1.3 2013/09/04 17:22:41 xarthisius Exp $
EAPI=5
@@ -21,6 +21,7 @@ RDEPEND="
sci-libs/hdf5:=
dev-python/numpy[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
diff --git a/dev-python/h5py/h5py-2.1.2-r1.ebuild b/dev-python/h5py/h5py-2.2.0.ebuild
index 98f3ebb80624..d304bdaf9fd6 100644
--- a/dev-python/h5py/h5py-2.1.2-r1.ebuild
+++ b/dev-python/h5py/h5py-2.2.0.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.1.2-r1.ebuild,v 1.1 2013/03/07 09:43:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.2.0.ebuild,v 1.1 2013/09/04 17:22:41 xarthisius Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit distutils-r1 flag-o-matic eutils
+inherit distutils-r1 flag-o-matic
-DESCRIPTION="A simple Python interface to HDF5 files"
-HOMEPAGE="http://h5py.alfven.org/ http://code.google.com/p/h5py/ http://pypi.python.org/pypi/h5py"
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
@@ -22,11 +22,11 @@ RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
python_prepare_all() {
append-cflags -fno-strict-aliasing
- epatch "${FILESDIR}"/${PN}-2.1-ucode.patch
}
python_test() {
@@ -34,7 +34,7 @@ python_test() {
}
python_install_all() {
- dodoc README.txt
+ dodoc README.rst ANN.rst
if use examples; then
docompress -x /usr/share/doc/${PF}/examples
insinto /usr/share/doc/${PF}