summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-06 10:57:58 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-06 10:57:58 +0000
commit3ad3065060a15a91292cbf8e10e1cf714076bc1c (patch)
treeb47725004ef9a40bdfbcac931d72b455e5f5501b /dev-python/gitdb
parentuse mirror (diff)
downloadgentoo-2-3ad3065060a15a91292cbf8e10e1cf714076bc1c.tar.gz
gentoo-2-3ad3065060a15a91292cbf8e10e1cf714076bc1c.tar.bz2
gentoo-2-3ad3065060a15a91292cbf8e10e1cf714076bc1c.zip
bump, tidy deps, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/gitdb')
-rw-r--r--dev-python/gitdb/ChangeLog10
-rw-r--r--dev-python/gitdb/gitdb-0.5.4-r1.ebuild24
-rw-r--r--dev-python/gitdb/gitdb-0.5.4.ebuild27
-rw-r--r--dev-python/gitdb/gitdb-0.6.1.ebuild24
4 files changed, 32 insertions, 53 deletions
diff --git a/dev-python/gitdb/ChangeLog b/dev-python/gitdb/ChangeLog
index 01b6636276a0..f342655b7fb6 100644
--- a/dev-python/gitdb/ChangeLog
+++ b/dev-python/gitdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gitdb
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/ChangeLog,v 1.5 2014/11/18 10:11:54 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/ChangeLog,v 1.6 2015/01/06 10:57:58 idella4 Exp $
+
+*gitdb-0.6.1 (06 Jan 2015)
+
+ 06 Jan 2015; Ian Delaney <idella4@gentoo.org> +gitdb-0.6.1.ebuild,
+ -gitdb-0.5.4-r1.ebuild, -gitdb-0.5.4.ebuild:
+ bump, tidy deps, rm old
*gitdb-0.6.0 (18 Nov 2014)
diff --git a/dev-python/gitdb/gitdb-0.5.4-r1.ebuild b/dev-python/gitdb/gitdb-0.5.4-r1.ebuild
deleted file mode 100644
index 84d4b9579b1a..000000000000
--- a/dev-python/gitdb/gitdb-0.5.4-r1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/gitdb-0.5.4-r1.ebuild,v 1.1 2013/05/07 14:47:15 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="GitDB is a pure-Python git object database"
-HOMEPAGE="https://github.com/gitpython-developers/gitdb
- http://pypi.python.org/pypi/gitdb"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-vcs/git
- >=dev-python/async-0.6[${PYTHON_USEDEP}]
- >=dev-python/smmap-0.8[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/gitdb/gitdb-0.5.4.ebuild b/dev-python/gitdb/gitdb-0.5.4.ebuild
deleted file mode 100644
index 2cf1c9b59d3d..000000000000
--- a/dev-python/gitdb/gitdb-0.5.4.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/gitdb-0.5.4.ebuild,v 1.3 2013/04/24 01:10:57 zx2c4 Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="GitDB is a pure-Python git object database"
-HOMEPAGE="https://github.com/gitpython-developers/gitdb
- http://pypi.python.org/pypi/gitdb"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-vcs/git
- >=dev-python/async-0.6
- >=dev-python/smmap-0.8"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-RESTRICT_PYTHON_ABIS="3.*"
diff --git a/dev-python/gitdb/gitdb-0.6.1.ebuild b/dev-python/gitdb/gitdb-0.6.1.ebuild
new file mode 100644
index 000000000000..de7470ed6172
--- /dev/null
+++ b/dev-python/gitdb/gitdb-0.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gitdb/gitdb-0.6.1.ebuild,v 1.1 2015/01/06 10:57:58 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ http://pypi.python.org/pypi/gitdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git
+ >=dev-python/smmap-0.8.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"