summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-06 12:14:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-06 12:14:50 +0000
commit5c4e1e5840f5f4fa6ba34606e87d77721b5de44a (patch)
treec667347a73e19f16d3e4f71916d532ff4c5777d4 /dev-python/geopy
parentnew RDEP to geopy-1.1.3, simple minimal ebuild (diff)
downloadgentoo-2-5c4e1e5840f5f4fa6ba34606e87d77721b5de44a.tar.gz
gentoo-2-5c4e1e5840f5f4fa6ba34606e87d77721b5de44a.tar.bz2
gentoo-2-5c4e1e5840f5f4fa6ba34606e87d77721b5de44a.zip
bump; drop py2.6 pypy2_0 add py3.4, switch SRC_URI to github.com once again due to an incomplete tarball @ pypi, upgrade deps & test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/geopy')
-rw-r--r--dev-python/geopy/ChangeLog8
-rw-r--r--dev-python/geopy/geopy-1.1.3.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/geopy/ChangeLog b/dev-python/geopy/ChangeLog
index 5750b8a88baf..9e53f0bf8411 100644
--- a/dev-python/geopy/ChangeLog
+++ b/dev-python/geopy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/geopy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/ChangeLog,v 1.9 2014/06/30 04:45:51 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/ChangeLog,v 1.10 2014/09/06 12:14:50 idella4 Exp $
+
+*geopy-1.1.3 (06 Sep 2014)
+
+ 06 Sep 2014; Ian Delaney <idella4@gentoo.org> +geopy-1.1.3.ebuild:
+ bump; drop py2.6 pypy2_0 add py3.4, switch SRC_URI to github.com once again
+ due to an incomplete tarball @ pypi, upgrade deps & test phase
30 Jun 2014; Mike Gilbert <floppym@gentoo.org> -geopy-0.95.1.ebuild,
-geopy-0.96.2.ebuild, -geopy-0.97.ebuild, geopy-0.99.ebuild:
diff --git a/dev-python/geopy/geopy-1.1.3.ebuild b/dev-python/geopy/geopy-1.1.3.ebuild
new file mode 100644
index 000000000000..70ee33c3f672
--- /dev/null
+++ b/dev-python/geopy/geopy-1.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/geopy-1.1.3.ebuild,v 1.1 2014/09/06 12:14:50 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Geocoding Toolbox for Python"
+HOMEPAGE="http://www.geopy.org/ http://pypi.python.org/pypi/geopy http://code.google.com/p/geopy/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="test yahoo"
+
+RDEPEND="yahoo? ( $(python_gen_cond_dep '>=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]' python2_7 'python{3_3,3_4}')
+ dev-python/placefinder[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}] )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ # https://github.com/geopy/geopy/issues/74
+ nosetests --processes=-1 || die "Tests failed under ${EPYTHON}"
+}