summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-02-26 03:10:23 +0000
committerMike Gilbert <floppym@gentoo.org>2012-02-26 03:10:23 +0000
commit0a9cb7c0c448093e5b78e7bd0c6881a5cd035c15 (patch)
tree6ade70c771cc2196551ac44db32e5b3e950eed28 /dev-python/gdata
parentRestricting jython (diff)
downloadgentoo-2-0a9cb7c0c448093e5b78e7bd0c6881a5cd035c15.tar.gz
gentoo-2-0a9cb7c0c448093e5b78e7bd0c6881a5cd035c15.tar.bz2
gentoo-2-0a9cb7c0c448093e5b78e7bd0c6881a5cd035c15.zip
Version bump. Resolves bug 398533.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/ChangeLog9
-rw-r--r--dev-python/gdata/gdata-2.0.16.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index 0f2dca0c02ef..c5bdefcb0539 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gdata
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.100 2011/06/23 15:06:32 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.101 2012/02/26 03:10:23 floppym Exp $
+
+*gdata-2.0.16 (26 Feb 2012)
+
+ 26 Feb 2012; Mike Gilbert <floppym@gentoo.org> +gdata-2.0.16.ebuild:
+ Version bump. Resolves bug 398533.
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -gdata-2.0.13.ebuild:
Remove old ebuilds. Requested by Arfrever
diff --git a/dev-python/gdata/gdata-2.0.16.ebuild b/dev-python/gdata/gdata-2.0.16.ebuild
new file mode 100644
index 000000000000..9aaa8cdf43de
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.16.ebuild,v 1.1 2012/02/26 03:10:23 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="ssl"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/ http://pypi.python.org/pypi/gdata"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND="|| ( dev-lang/python:2.7[xml] dev-lang/python:2.6[xml] dev-lang/python:2.5[xml] dev-python/elementtree )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="atom gdata"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_data_tests.py -v || return 1
+
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ # PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_service_tests.py -v || return 1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "Installation of examples failed"
+ fi
+}