summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-21 07:54:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-21 07:54:02 +0000
commit522ceb24cbc0266931f73a4198f16f15d69cc62b (patch)
treebe66ff437bd9a61f3f086ffc266eb6f047ed1912 /dev-python/flask-wtf
parentStable for amd64 wrt bug #512332 (diff)
downloadgentoo-2-522ceb24cbc0266931f73a4198f16f15d69cc62b.tar.gz
gentoo-2-522ceb24cbc0266931f73a4198f16f15d69cc62b.tar.bz2
gentoo-2-522ceb24cbc0266931f73a4198f16f15d69cc62b.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-wtf')
-rw-r--r--dev-python/flask-wtf/ChangeLog7
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.10.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/flask-wtf/ChangeLog b/dev-python/flask-wtf/ChangeLog
index 040e4eb3246c..2b820b1940fa 100644
--- a/dev-python/flask-wtf/ChangeLog
+++ b/dev-python/flask-wtf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-wtf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/ChangeLog,v 1.12 2014/05/07 07:08:12 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/ChangeLog,v 1.13 2014/07/21 07:54:02 patrick Exp $
+
+*flask-wtf-0.10.0 (21 Jul 2014)
+
+ 21 Jul 2014; Patrick Lauer <patrick@gentoo.org> +flask-wtf-0.10.0.ebuild:
+ Bump
07 May 2014; Ian Delaney <idella4@gentoo.org> flask-wtf-0.9.5.ebuild:
drop py2.6 add pypy support, add IUSE doc & all to build & install docs
diff --git a/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild b/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild
new file mode 100644
index 000000000000..395771fdeb61
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-wtf/flask-wtf-0.10.0.ebuild,v 1.1 2014/07/21 07:54:02 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration."
+HOMEPAGE="http://pythonhosted.org/Flask-WTF/ https://pypi.python.org/pypi/Flask-WTF"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-testing[${PYTHON_USEDEP}]
+ dev-python/flask-uploads[${PYTHON_USEDEP}]
+ dev-python/speaklater[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}