summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-14 14:01:54 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-14 14:01:54 +0000
commit3ab830dc91b2e035f168ebb2a78fc4006855c24a (patch)
treea33110beadc677cdd414533c9ec663b87b42ad75 /dev-python/flask-security
parentclean old python impls, drop unused IUSE add doc examples, doc build (diff)
downloadgentoo-2-3ab830dc91b2e035f168ebb2a78fc4006855c24a.tar.gz
gentoo-2-3ab830dc91b2e035f168ebb2a78fc4006855c24a.tar.bz2
gentoo-2-3ab830dc91b2e035f168ebb2a78fc4006855c24a.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/ChangeLog7
-rw-r--r--dev-python/flask-security/flask-security-1.7.3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/flask-security/ChangeLog b/dev-python/flask-security/ChangeLog
index ed147053986f..a9a228fda56b 100644
--- a/dev-python/flask-security/ChangeLog
+++ b/dev-python/flask-security/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-security
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-security/ChangeLog,v 1.4 2014/05/20 07:43:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-security/ChangeLog,v 1.5 2014/06/14 14:01:54 idella4 Exp $
+
+*flask-security-1.7.3 (14 Jun 2014)
+
+ 14 Jun 2014; Ian Delaney <idella4@gentoo.org> +flask-security-1.7.3.ebuild:
+ bump
*flask-security-1.7.2 (20 May 2014)
diff --git a/dev-python/flask-security/flask-security-1.7.3.ebuild b/dev-python/flask-security/flask-security-1.7.3.ebuild
new file mode 100644
index 000000000000..b4cec4aa8d46
--- /dev/null
+++ b/dev-python/flask-security/flask-security-1.7.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-security/flask-security-1.7.3.ebuild,v 1.1 2014/06/14 14:01:54 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-Security"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="http://pythonhosted.org/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# packages of this type require local running instances of databases
+# which then require connect to localhost
+RESTRICT="test"
+
+RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.17[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.7.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.8[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+ dev-python/flask-peewee[${PYTHON_USEDEP}]
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}