summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-24 02:35:28 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-24 02:35:28 +0000
commit809671f359f19218bf66c8dd1f07b6fb0d5571b3 (patch)
tree404bc8bc913712923e74a7bc3b9ba6be55384d96 /dev-python/flask-openid
parentUpdate generic mach_dep for ASM_CLEAR_CODE targets (diff)
downloadgentoo-2-809671f359f19218bf66c8dd1f07b6fb0d5571b3.tar.gz
gentoo-2-809671f359f19218bf66c8dd1f07b6fb0d5571b3.tar.bz2
gentoo-2-809671f359f19218bf66c8dd1f07b6fb0d5571b3.zip
Initial addition (bug #328743).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/flask-openid')
-rw-r--r--dev-python/flask-openid/ChangeLog10
-rw-r--r--dev-python/flask-openid/flask-openid-1.0.1.ebuild54
-rw-r--r--dev-python/flask-openid/metadata.xml5
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/flask-openid/ChangeLog b/dev-python/flask-openid/ChangeLog
new file mode 100644
index 000000000000..edf818945d6e
--- /dev/null
+++ b/dev-python/flask-openid/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/flask-openid
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/ChangeLog,v 1.1 2010/07/24 02:35:28 arfrever Exp $
+
+*flask-openid-1.0.1 (24 Jul 2010)
+
+ 24 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +flask-openid-1.0.1.ebuild, +metadata.xml:
+ Initial addition (bug #328743).
+
diff --git a/dev-python/flask-openid/flask-openid-1.0.1.ebuild b/dev-python/flask-openid/flask-openid-1.0.1.ebuild
new file mode 100644
index 000000000000..6171c35e89f8
--- /dev/null
+++ b/dev-python/flask-openid/flask-openid-1.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/flask-openid-1.0.1.ebuild,v 1.1 2010/07/24 02:35:28 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="Flask-OpenID"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="OpenID support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-OpenID"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/flask-0.3
+ >=dev-python/python-openid-2.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="flaskext/openid.py"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example || die "Installation of examples failed"
+ fi
+}
diff --git a/dev-python/flask-openid/metadata.xml b/dev-python/flask-openid/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/flask-openid/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>