summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-31 07:10:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-31 07:10:05 +0000
commit7b225f15e934419686dff5130b1ed46d984c3455 (patch)
tree6912a50c615e91b2a989dd78b63c9d5fd93e82f2 /dev-python/flask-openid
parentVersion bump committed on behalf of Jamie Learmonth (diff)
downloadgentoo-2-7b225f15e934419686dff5130b1ed46d984c3455.tar.gz
gentoo-2-7b225f15e934419686dff5130b1ed46d984c3455.tar.bz2
gentoo-2-7b225f15e934419686dff5130b1ed46d984c3455.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-openid')
-rw-r--r--dev-python/flask-openid/ChangeLog10
-rw-r--r--dev-python/flask-openid/flask-openid-1.1.ebuild54
2 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/flask-openid/ChangeLog b/dev-python/flask-openid/ChangeLog
index 685f8e6a6e1a..e4632921e17b 100644
--- a/dev-python/flask-openid/ChangeLog
+++ b/dev-python/flask-openid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-openid
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/ChangeLog,v 1.2 2011/10/08 17:46:15 floppym Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/ChangeLog,v 1.3 2012/10/31 07:10:05 patrick Exp $
+
+*flask-openid-1.1 (31 Oct 2012)
+
+ 31 Oct 2012; Patrick Lauer <patrick@gentoo.org> +flask-openid-1.1.ebuild:
+ Bump
08 Oct 2011; Mike Gilbert <floppym@gentoo.org> flask-openid-1.0.1.ebuild:
Restrict py2.4 due to bug 382765.
@@ -10,4 +15,3 @@
24 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+flask-openid-1.0.1.ebuild, +metadata.xml:
Initial addition (bug #328743).
-
diff --git a/dev-python/flask-openid/flask-openid-1.1.ebuild b/dev-python/flask-openid/flask-openid-1.1.ebuild
new file mode 100644
index 000000000000..b5f1279cb4f4
--- /dev/null
+++ b/dev-python/flask-openid/flask-openid-1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/flask-openid-1.1.ebuild,v 1.1 2012/10/31 07:10:04 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+MY_PN="Flask-OpenID"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="OpenID support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-OpenID"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/flask-0.3
+ >=dev-python/python-openid-2.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="flaskext/openid.py"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example || die "Installation of examples failed"
+ fi
+}