summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-25 06:58:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-25 06:58:35 +0000
commit2bff1296a6e7d48de37899ac22b0551ad7f8011e (patch)
tree6fe641f11cf2584c236d570312f1c39fef1a088a /dev-python/flask-openid
parentpoint HOMEPAGE at an actual web page (diff)
downloadgentoo-2-2bff1296a6e7d48de37899ac22b0551ad7f8011e.tar.gz
gentoo-2-2bff1296a6e7d48de37899ac22b0551ad7f8011e.tar.bz2
gentoo-2-2bff1296a6e7d48de37899ac22b0551ad7f8011e.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-openid')
-rw-r--r--dev-python/flask-openid/ChangeLog9
-rw-r--r--dev-python/flask-openid/flask-openid-1.1.1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-python/flask-openid/ChangeLog b/dev-python/flask-openid/ChangeLog
index e4632921e17b..1690dea12879 100644
--- a/dev-python/flask-openid/ChangeLog
+++ b/dev-python/flask-openid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-openid
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/ChangeLog,v 1.3 2012/10/31 07:10:05 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/ChangeLog,v 1.4 2013/01/25 06:58:35 patrick Exp $
+
+*flask-openid-1.1.1 (25 Jan 2013)
+
+ 25 Jan 2013; Patrick Lauer <patrick@gentoo.org> +flask-openid-1.1.1.ebuild:
+ Bump
*flask-openid-1.1 (31 Oct 2012)
diff --git a/dev-python/flask-openid/flask-openid-1.1.1.ebuild b/dev-python/flask-openid/flask-openid-1.1.1.ebuild
new file mode 100644
index 000000000000..47fc7545ce75
--- /dev/null
+++ b/dev-python/flask-openid/flask-openid-1.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-openid/flask-openid-1.1.1.ebuild,v 1.1 2013/01/25 06:58:35 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+MY_PN="Flask-OpenID"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="OpenID support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-OpenID"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/flask-0.3
+ >=dev-python/python-openid-2.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example || die "Installation of examples failed"
+ fi
+}