summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-11 14:20:03 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-11 14:20:03 +0000
commitff7bbee65f263d798da08f3f07692b7ceee96c53 (patch)
tree28cd8c694434a50ee54258056c2f69edcf3074fc /dev-python/eyeD3
parentvanilla-3.14.6 + genpatches-3.14-10 + grsecurity-3.0-3.14.6-201406101411 (diff)
downloadgentoo-2-ff7bbee65f263d798da08f3f07692b7ceee96c53.tar.gz
gentoo-2-ff7bbee65f263d798da08f3f07692b7ceee96c53.tar.bz2
gentoo-2-ff7bbee65f263d798da08f3f07692b7ceee96c53.zip
Convert the :0 slot to distutils-r1. Clean up.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/eyeD3')
-rw-r--r--dev-python/eyeD3/ChangeLog7
-rw-r--r--dev-python/eyeD3/eyeD3-0.6.18-r2.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/eyeD3/ChangeLog b/dev-python/eyeD3/ChangeLog
index 0a21b5e8d889..8e10d74b8773 100644
--- a/dev-python/eyeD3/ChangeLog
+++ b/dev-python/eyeD3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/eyeD3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.70 2014/06/11 14:06:32 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.71 2014/06/11 14:20:03 mgorny Exp $
+
+*eyeD3-0.6.18-r2 (11 Jun 2014)
+
+ 11 Jun 2014; Michał Górny <mgorny@gentoo.org> +eyeD3-0.6.18-r2.ebuild:
+ Convert the :0 slot to distutils-r1. Clean up.
11 Jun 2014; Michał Górny <mgorny@gentoo.org> eyeD3-0.7.4-r2.ebuild:
Remove the python-magic dependency wrt bug #488270, and remove the pavement.py
diff --git a/dev-python/eyeD3/eyeD3-0.6.18-r2.ebuild b/dev-python/eyeD3/eyeD3-0.6.18-r2.ebuild
new file mode 100644
index 000000000000..ba0adc443264
--- /dev/null
+++ b/dev-python/eyeD3/eyeD3-0.6.18-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/eyeD3-0.6.18-r2.ebuild,v 1.1 2014/06/11 14:20:03 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
+HOMEPAGE="http://eyed3.nicfit.net/"
+SRC_URI="http://eyed3.nicfit.net/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+python_configure_all() {
+ econf
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ local HTML_DOCS=( *.html )
+ distutils-r1_python_install_all
+}