summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-05 20:57:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-05 20:57:15 +0000
commit52ceeb0ae44b206ab0a5f1bfcb3788b42732b68a (patch)
tree0b9a285048281ef5a72a61cef9bcc0aecfd31fc2 /dev-python/enthoughtbase
parentamd64 stable wrt bug #282179 (diff)
downloadgentoo-2-52ceeb0ae44b206ab0a5f1bfcb3788b42732b68a.tar.gz
gentoo-2-52ceeb0ae44b206ab0a5f1bfcb3788b42732b68a.tar.bz2
gentoo-2-52ceeb0ae44b206ab0a5f1bfcb3788b42732b68a.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14200-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/enthoughtbase')
-rw-r--r--dev-python/enthoughtbase/ChangeLog8
-rw-r--r--dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild (renamed from dev-python/enthoughtbase/enthoughtbase-3.0.1.ebuild)25
2 files changed, 24 insertions, 9 deletions
diff --git a/dev-python/enthoughtbase/ChangeLog b/dev-python/enthoughtbase/ChangeLog
index 4fbeba643207..5ead0c4ceaae 100644
--- a/dev-python/enthoughtbase/ChangeLog
+++ b/dev-python/enthoughtbase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/enthoughtbase
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/ChangeLog,v 1.5 2009/07/01 08:08:29 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/ChangeLog,v 1.6 2009/09/05 20:57:15 arfrever Exp $
+
+*enthoughtbase-3.0.3 (05 Sep 2009)
+
+ 05 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -enthoughtbase-3.0.1.ebuild, +enthoughtbase-3.0.3.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*enthoughtbase-3.0.2 (27 Mar 2009)
diff --git a/dev-python/enthoughtbase/enthoughtbase-3.0.1.ebuild b/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild
index 12c592d7d2cc..84cebbb29aa6 100644
--- a/dev-python/enthoughtbase/enthoughtbase-3.0.1.ebuild
+++ b/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.1.ebuild,v 1.2 2009/02/12 11:55:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild,v 1.1 2009/09/05 20:57:15 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
-EAPI=2
inherit distutils
MY_PN="EnthoughtBase"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Core packages for the Enthought Tool Suite"
HOMEPAGE="http://code.enthought.com/projects/enthought_base.php"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
IUSE="doc examples"
SLOT="0"
@@ -18,15 +20,19 @@ LICENSE="BSD LGPL-2"
RDEPEND=""
DEPEND="dev-python/setuptools
doc? ( dev-python/setupdocs )"
-# test? ( >=dev-python/nose-0.10.3 dev-python/etsdevtools )"
-# tests need an X display
-RESTRICT=test
+# tests would require circular deps
+# test? ( >=dev-python/nose-0.10.3
+# dev-python/traits
+# dev-python/etsdevtools )"
+RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT="test"
+
S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="enthought"
src_prepare() {
- sed -i -e "/self.run_command('build_docs')/d" setup.py || die
+ sed -i -e "s/self.run_command('build_docs')/pass/" setup.py || die
}
src_compile() {
@@ -39,7 +45,10 @@ src_compile() {
}
src_test() {
- PYTHONPATH=build/lib ${python} setup.py test || die "tests failed"
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
+ }
+ python_execute_function
}
src_install() {