summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-05-26 18:15:28 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-05-26 18:15:28 +0000
commit4fc043328af052975773d1e31e61579f2d5c81b1 (patch)
tree64e33e5f6f1ce3f23bb959677212873ccd17ae2b /dev-python/django
parentMarked ~hppa (bug #223557). (diff)
downloadgentoo-2-4fc043328af052975773d1e31e61579f2d5c81b1.tar.gz
gentoo-2-4fc043328af052975773d1e31e61579f2d5c81b1.tar.bz2
gentoo-2-4fc043328af052975773d1e31e61579f2d5c81b1.zip
Version bump to fix security bug, see bug #222029.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog10
-rw-r--r--dev-python/django/django-0.96.2.ebuild (renamed from dev-python/django/django-0.96.1.ebuild)24
2 files changed, 29 insertions, 5 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 127a846c8752..59b56d80b4bd 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.21 2007/12/25 14:50:09 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.22 2008/05/26 18:15:28 nelchael Exp $
+
+*django-0.96.2 (26 May 2008)
+
+ 26 May 2008; Krzysiek Pawlik <nelchael@gentoo.org> -django-0.96.1.ebuild,
+ +django-0.96.2.ebuild:
+ Version bump to fix security bug, see bug #222029.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing seemant from metadata.xml as per #202469.
diff --git a/dev-python/django/django-0.96.1.ebuild b/dev-python/django/django-0.96.2.ebuild
index 48fd2fcb84dc..2c650593f78c 100644
--- a/dev-python/django/django-0.96.1.ebuild
+++ b/dev-python/django/django-0.96.2.ebuild
@@ -1,16 +1,20 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.96.1.ebuild,v 1.1 2007/10/27 12:10:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.96.2.ebuild,v 1.1 2008/05/26 18:15:28 nelchael Exp $
inherit bash-completion distutils eutils versionator
RPV=$(get_version_component_range 1-2)
+EXTRAS_VERSION="0.96.1"
MY_P="Django-${PV}"
DESCRIPTION="high-level python web framework"
HOMEPAGE="http://www.djangoproject.com/"
-SRC_URI="http://media.djangoproject.com/releases/${RPV}/${MY_P}.tar.gz"
+SRC_URI="http://media.djangoproject.com/releases/${RPV}/${MY_P}.tar.gz
+ http://media.djangoproject.com/releases/${RPV}/Django-${EXTRAS_VERSION}.tar.gz"
+ # We need ${EXTRAS_VERSION} in SRC_URI, because it's the last release that
+ # contains extras, tests and examples, see also src_unpack
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
@@ -31,6 +35,20 @@ S="${WORKDIR}/${MY_P}"
DOCS="docs/* AUTHORS"
+src_unpack() {
+
+ distutils_src_unpack
+
+ # Those directories are missing from 0.96.2, so we copy them over from
+ # Django-${EXTRAS_VERSION}:
+ cp -a "${WORKDIR}/Django-${EXTRAS_VERSION}/examples" "${S}/" || die
+ cp -a "${WORKDIR}/Django-${EXTRAS_VERSION}/extras" "${S}/" || die
+ cp -a "${WORKDIR}/Django-${EXTRAS_VERSION}/tests" "${S}/" || die
+ cp -a "${WORKDIR}/Django-${EXTRAS_VERSION}/django/contrib/formtools/templates" \
+ "${S}/django/contrib/formtools/" || die
+
+}
+
src_test() {
cat >> tests/settings.py << __EOF__
DATABASE_ENGINE='sqlite3'