summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-28 15:55:52 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-28 15:55:52 +0000
commit0752fc05e1307d080fb77821c48c0a4d1bbdd36d (patch)
tree12f798927674d42c86718529a1ea3d9463e42d69 /dev-python/django-social-auth
parentRemove useless extern, fixes compile on uclibc, bug #469954 (diff)
downloadgentoo-2-0752fc05e1307d080fb77821c48c0a4d1bbdd36d.tar.gz
gentoo-2-0752fc05e1307d080fb77821c48c0a4d1bbdd36d.tar.bz2
gentoo-2-0752fc05e1307d080fb77821c48c0a4d1bbdd36d.zip
bump, remove old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-social-auth')
-rw-r--r--dev-python/django-social-auth/ChangeLog10
-rw-r--r--dev-python/django-social-auth/django-social-auth-0.6.8.ebuild27
-rw-r--r--dev-python/django-social-auth/django-social-auth-0.7.23.ebuild40
3 files changed, 48 insertions, 29 deletions
diff --git a/dev-python/django-social-auth/ChangeLog b/dev-python/django-social-auth/ChangeLog
index e5069dbe145a..aa1ddad5966d 100644
--- a/dev-python/django-social-auth/ChangeLog
+++ b/dev-python/django-social-auth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-social-auth
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/ChangeLog,v 1.2 2012/11/13 10:34:30 idella4 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/ChangeLog,v 1.3 2013/05/28 15:55:52 idella4 Exp $
+
+*django-social-auth-0.7.23 (28 May 2013)
+
+ 28 May 2013; Ian Delaney <idella4@gentoo.org>
+ +django-social-auth-0.7.23.ebuild, -django-social-auth-0.6.8.ebuild:
+ bump, remove old
14 Nov 2012; Ian Delaney <idella4@gentoo.org> metadata.xml:
Updating maintainer, metadata.xml
diff --git a/dev-python/django-social-auth/django-social-auth-0.6.8.ebuild b/dev-python/django-social-auth/django-social-auth-0.6.8.ebuild
deleted file mode 100644
index e59a03abee0f..000000000000
--- a/dev-python/django-social-auth/django-social-auth-0.6.8.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/django-social-auth-0.6.8.ebuild,v 1.1 2012/04/25 18:58:58 tampakrap Exp $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="An easy to setup social authentication/authorization mechanism for Django projects"
-HOMEPAGE="http://pypi.python.org/pypi/django-social-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-LICENSE="MIT"
-SLOT="0"
-PYTHON_MODNAME="social_auth"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/django
- dev-python/setuptools
- >=dev-python/oauth2-1.5.167
- >=dev-python/python-openid-2.2"
diff --git a/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild b/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild
new file mode 100644
index 000000000000..92a5827ccec3
--- /dev/null
+++ b/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild,v 1.1 2013/05/28 15:55:52 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy to setup social authentication/authorization mechanism for Django projects"
+HOMEPAGE="http://pypi.python.org/pypi/django-social-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-python/django-1.3.2[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]
+ >=dev-python/python-openid-2.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ export SECRET_KEY='green'
+ local test
+ for test in social_auth/tests/{base.py,client.py,facebook.py,google.py,odnoklassniki.py,twitter.py}
+ do
+ if ! "${PYTHON}" -c \
+ "from django.conf import global_settings;global_settings.SECRET_KEY='$SECRET_KEY'" $test
+ then
+ die "test ${test} failed under ${EPYTHON}"
+ else
+ einfo "test ${test} passed"
+ fi
+ done
+ einfo "All tests passed under ${EPYTHON}"
+}