summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-11 06:29:13 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-11 06:29:13 +0000
commit97002e3a14409d08e142185d2bf4ba12995d7628 (patch)
treeccde2631458dfe34308f0d4eb60340347f2c37d4 /dev-python/django-celery
parentunmask django-celery-3.1.9, celery-3.1.10 (diff)
downloadgentoo-2-97002e3a14409d08e142185d2bf4ba12995d7628.tar.gz
gentoo-2-97002e3a14409d08e142185d2bf4ba12995d7628.tar.bz2
gentoo-2-97002e3a14409d08e142185d2bf4ba12995d7628.zip
bump; update dep celery to both 3.1 versions
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-celery')
-rw-r--r--dev-python/django-celery/ChangeLog9
-rw-r--r--dev-python/django-celery/django-celery-3.0.21.ebuild48
-rw-r--r--dev-python/django-celery/django-celery-3.1.10.ebuild (renamed from dev-python/django-celery/django-celery-3.0.17-r1.ebuild)27
-rw-r--r--dev-python/django-celery/django-celery-3.1.9.ebuild4
4 files changed, 28 insertions, 60 deletions
diff --git a/dev-python/django-celery/ChangeLog b/dev-python/django-celery/ChangeLog
index 975316a20511..828a8cb6177c 100644
--- a/dev-python/django-celery/ChangeLog
+++ b/dev-python/django-celery/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/django-celery
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/ChangeLog,v 1.16 2014/04/09 11:01:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/ChangeLog,v 1.17 2014/04/11 06:29:13 idella4 Exp $
+
+*django-celery-3.1.10 (11 Apr 2014)
+
+ 11 Apr 2014; Ian Delaney <idella4@gentoo.org> +django-celery-3.1.10.ebuild,
+ -django-celery-3.0.17-r1.ebuild, -django-celery-3.0.21.ebuild,
+ django-celery-3.1.9.ebuild:
+ bump; update dep celery to both 3.1 versions
*django-celery-3.1.9 (09 Apr 2014)
diff --git a/dev-python/django-celery/django-celery-3.0.21.ebuild b/dev-python/django-celery/django-celery-3.0.21.ebuild
deleted file mode 100644
index 46279712ecf2..000000000000
--- a/dev-python/django-celery/django-celery-3.0.21.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/django-celery-3.0.21.ebuild,v 1.1 2013/08/10 12:50:21 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Celery Integration for Django"
-HOMEPAGE="http://celeryproject.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/celery-3.0.17[${PYTHON_USEDEP}]
- >=dev-python/django-1.3[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- virtual/python-unittest2[${PYTHON_USEDEP}]
- dev-python/django-nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose-cover3[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/python-memcached )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-issuetracker[${PYTHON_USEDEP}]
- dev-python/python-memcached
- )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- python tests/manage.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/.build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-celery/django-celery-3.0.17-r1.ebuild b/dev-python/django-celery/django-celery-3.1.10.ebuild
index dd8ce992880b..0e15e0897ebc 100644
--- a/dev-python/django-celery/django-celery-3.0.17-r1.ebuild
+++ b/dev-python/django-celery/django-celery-3.1.10.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/django-celery-3.0.17-r1.ebuild,v 1.3 2013/05/21 18:23:22 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/django-celery-3.1.10.ebuild,v 1.1 2014/04/11 06:29:13 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_3} )
inherit distutils-r1
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"
-RDEPEND=">=dev-python/celery-3.0.17[${PYTHON_USEDEP}]
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND=">=dev-python/celery-3.1.10[${PYTHON_USEDEP}]
>=dev-python/django-1.3[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
@@ -24,21 +25,29 @@ DEPEND="${RDEPEND}
test? (
virtual/python-unittest2[${PYTHON_USEDEP}]
dev-python/django-nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.0[${PYTHON_USEDEP}]
dev-python/nose-cover3[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/python-memcached )
+ dev-python/python-memcached[${PY2_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-issuetracker[${PYTHON_USEDEP}]
- dev-python/python-memcached
+ dev-python/sphinxcontrib-issuetracker[${PY2_USEDEP}]
+ dev-python/python-memcached[${PY2_USEDEP}]
)"
+PY27_REQUSE="$(python_gen_useflags 'python2.7')"
+REQUIRED_USE="
+ doc? ( ${PY27_REQUSE} )"
+
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- python tests/manage.py test
+ # py3 has masses of errors
+ # https://github.com/celery/django-celery/issues/321
+ if ! python_is_python3; then
+ "${PYTHON}" tests/manage.py test
+ fi
}
python_install_all() {
diff --git a/dev-python/django-celery/django-celery-3.1.9.ebuild b/dev-python/django-celery/django-celery-3.1.9.ebuild
index 3409e9da2213..d575518b3c93 100644
--- a/dev-python/django-celery/django-celery-3.1.9.ebuild
+++ b/dev-python/django-celery/django-celery-3.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/django-celery-3.1.9.ebuild,v 1.1 2014/04/09 11:01:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-celery/django-celery-3.1.9.ebuild,v 1.2 2014/04/11 06:29:13 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"
PY2_USEDEP=$(python_gen_usedep python2_7)
-RDEPEND=">=dev-python/celery-3.0.19[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/celery-3.1.9[${PYTHON_USEDEP}]
>=dev-python/django-1.3[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}