summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-11 02:50:12 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-11 02:50:12 +0000
commitd2c90fdc5764ca44cc2efeb5f994fdb333663a61 (patch)
tree0dfc78b5bed2b66af0ae9636852d9d254b9f891f /dev-python/cherrypy
parentFix build and dependencies with USE="lua -jit" (bug #551704, thanks to tman a... (diff)
downloadgentoo-2-d2c90fdc5764ca44cc2efeb5f994fdb333663a61.tar.gz
gentoo-2-d2c90fdc5764ca44cc2efeb5f994fdb333663a61.tar.bz2
gentoo-2-d2c90fdc5764ca44cc2efeb5f994fdb333663a61.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/ChangeLog8
-rw-r--r--dev-python/cherrypy/cherrypy-3.3.0.ebuild4
-rw-r--r--dev-python/cherrypy/cherrypy-3.7.0.ebuild52
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index c3bdecb10d7b..8dbfeeebc06b 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cherrypy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.73 2015/06/07 10:05:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.74 2015/06/11 02:50:12 idella4 Exp $
+
+*cherrypy-3.7.0 (11 Jun 2015)
+
+ 11 Jun 2015; Ian Delaney <idella4@gentoo.org> +cherrypy-3.7.0.ebuild,
+ cherrypy-3.3.0.ebuild:
+ bump
07 Jun 2015; Markus Meier <maekke@gentoo.org> cherrypy-3.3.0.ebuild:
arm stable, bug #540290
diff --git a/dev-python/cherrypy/cherrypy-3.3.0.ebuild b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
index 1a106de36ce4..3d37ae2e3832 100644
--- a/dev-python/cherrypy/cherrypy-3.3.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.3.0.ebuild,v 1.10 2015/06/07 10:05:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.3.0.ebuild,v 1.11 2015/06/11 02:50:12 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/cherrypy/cherrypy-3.7.0.ebuild b/dev-python/cherrypy/cherrypy-3.7.0.ebuild
new file mode 100644
index 000000000000..312f75bad293
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-3.7.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.7.0.ebuild,v 1.1 2015/06/11 02:50:12 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.3.3[${PYTHON_USEDEP}] )"
+RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+# testsuite predominantly connects to the network
+RESTRICT="test"
+
+python_prepare_all() {
+ # Prevent interactive failures (hangs) in the test suite
+ sed -i -e "s/interactive = True/interactive = False/" cherrypy/test/webtest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # suite requires current latest nose-1.3.3
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1308
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1306
+ local exclude=(
+ -e test_file_stream -e test_4_File_deletion -e test_3_Redirect
+ -e test_2_File_Concurrency -e test_0_Session -e testStatic
+ )
+
+ # This really doesn't sit well with multiprocessing
+ # The issue 1306 tells us some tests are subject to the deleterious effects of
+ # the 'race condition'. Both the issues are unresolved / open
+# if [[ "${EPYTHON}" == pypy ]]; then
+ nosetests "${exclude[@]}" -I test_logging.py || die "Testing failed with ${EPYTHON}"
+# else
+# nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
+# fi
+}