summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-05-03 16:51:59 +0000
committerMike Gilbert <floppym@gentoo.org>2014-05-03 16:51:59 +0000
commit0c3f20eac4e08506608dd216a6d391e75ee89ad9 (patch)
tree5941d0577aa67bd672f3397b3958a1f57b88d657 /dev-python/cherrypy
parentVersion bump #509290 by MJJoker. (diff)
downloadgentoo-2-0c3f20eac4e08506608dd216a6d391e75ee89ad9.tar.gz
gentoo-2-0c3f20eac4e08506608dd216a6d391e75ee89ad9.tar.bz2
gentoo-2-0c3f20eac4e08506608dd216a6d391e75ee89ad9.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/ChangeLog8
-rw-r--r--dev-python/cherrypy/cherrypy-3.3.0.ebuild54
-rw-r--r--dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch12
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index 5e252db0bd5a..8d0fce2254ee 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cherrypy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.60 2014/04/05 21:07:43 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.61 2014/05/03 16:51:59 floppym Exp $
+
+*cherrypy-3.3.0 (03 May 2014)
+
+ 03 May 2014; Mike Gilbert <floppym@gentoo.org> +cherrypy-3.3.0.ebuild,
+ +files/cherrypy-3.3.0-test_config.patch:
+ Version bump.
05 Apr 2014; Mike Gilbert <floppym@gentoo.org>
+files/cherrypy-3.2.5-issue1234.patch, cherrypy-3.2.5.ebuild:
diff --git a/dev-python/cherrypy/cherrypy-3.3.0.ebuild b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
new file mode 100644
index 000000000000..b6ecb21404bd
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.3.0.ebuild,v 1.1 2014/05/03 16:51:59 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.0-test_config.patch" )
+
+python_prepare_all() {
+ # Prevent interactive failures (hangs) in the test suite
+ sed -i -e "s/interactive = True/interactive = False/" cherrypy/test/webtest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local exclude=(
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1306
+ -e test_session
+
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1308
+ -e test_file_stream
+
+ # https://bitbucket.org/cherrypy/cherrypy/issue/1315
+ -e test_HTTP11_pipelining
+ )
+
+ # This really doesn't sit well with multiprocessing
+ nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
+}
+
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
diff --git a/dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch b/dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch
new file mode 100644
index 000000000000..24d96eb2e2f5
--- /dev/null
+++ b/dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch
@@ -0,0 +1,12 @@
+diff --git a/cherrypy/test/test_config.py b/cherrypy/test/test_config.py
+--- a/cherrypy/test/test_config.py
++++ b/cherrypy/test/test_config.py
+@@ -206,7 +206,7 @@
+
+ if not compat.py3k:
+ self.getPage("/repr?key=thing3")
+- self.assertBody(repr(u'test'))
++ self.assertBody(repr(unicode('test')))
+
+ self.getPage("/repr?key=complex")
+ self.assertBody("(3+2j)")