summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-02-17 17:56:49 +0000
committerDirkjan Ochtman <djc@gentoo.org>2015-02-17 17:56:49 +0000
commit29296f396a7eef4935b7b6605c47fbff11433ca1 (patch)
tree159a275afa5510937030af66e55d881b422400a7 /dev-python/chardet/chardet-2.3.0.ebuild
parentfont-util-1.3.0: Add ~ppc-aix keyword. (diff)
downloadgentoo-2-29296f396a7eef4935b7b6605c47fbff11433ca1.tar.gz
gentoo-2-29296f396a7eef4935b7b6605c47fbff11433ca1.tar.bz2
gentoo-2-29296f396a7eef4935b7b6605c47fbff11433ca1.zip
Version bump chardet to 2.3.0 (fixes bug 540332)
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/chardet/chardet-2.3.0.ebuild')
-rw-r--r--dev-python/chardet/chardet-2.3.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/chardet/chardet-2.3.0.ebuild b/dev-python/chardet/chardet-2.3.0.ebuild
new file mode 100644
index 000000000000..a30526859ba6
--- /dev/null
+++ b/dev-python/chardet/chardet-2.3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chardet/chardet-2.3.0.ebuild,v 1.1 2015/02/17 17:56:49 djc Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="https://github.com/chardet/chardet http://pypi.python.org/pypi/chardet"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"