summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-15 04:39:30 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-15 04:39:30 +0000
commitfa83c589156320ecb85027ffd7bfaa50545f7062 (patch)
tree6933e6ba03392f184a9b932af062dc70718d36cb /dev-python/chaco
parentOld. (diff)
downloadgentoo-2-fa83c589156320ecb85027ffd7bfaa50545f7062.tar.gz
gentoo-2-fa83c589156320ecb85027ffd7bfaa50545f7062.tar.bz2
gentoo-2-fa83c589156320ecb85027ffd7bfaa50545f7062.zip
bump; update deps, add fix to qa issue in the build, correction to test phase
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/chaco')
-rw-r--r--dev-python/chaco/ChangeLog7
-rw-r--r--dev-python/chaco/chaco-4.5.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/chaco/ChangeLog b/dev-python/chaco/ChangeLog
index 2753aad2e9e9..2920ed008840 100644
--- a/dev-python/chaco/ChangeLog
+++ b/dev-python/chaco/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chaco
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.22 2014/01/29 17:39:35 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.23 2014/11/15 04:39:30 idella4 Exp $
+
+*chaco-4.5.0 (15 Nov 2014)
+
+ 15 Nov 2014; Ian Delaney <idella4@gentoo.org> +chaco-4.5.0.ebuild:
+ bump; update deps, add fix to qa issue in the build, correction to test phase
*chaco-4.4.1 (29 Jan 2014)
diff --git a/dev-python/chaco/chaco-4.5.0.ebuild b/dev-python/chaco/chaco-4.5.0.ebuild
new file mode 100644
index 000000000000..17dc475b4997
--- /dev/null
+++ b/dev-python/chaco/chaco-4.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-4.5.0.ebuild,v 1.1 2014/11/15 04:39:30 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx flag-o-matic
+
+DESCRIPTION="Enthought Tool Suite: Interactive plotting toolkit"
+HOMEPAGE="http://code.enthought.com/projects/chaco/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/enable-4.4.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}