summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-15 15:12:42 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-15 15:12:42 +0000
commit03f0685c89174f502947c1b6196653245ac984f6 (patch)
tree9a61a9485598da2e2b9943e8b668b1ac4961c703 /dev-python/chaco
parentAdd slot operator deps to latest version. (diff)
downloadgentoo-2-03f0685c89174f502947c1b6196653245ac984f6.tar.gz
gentoo-2-03f0685c89174f502947c1b6196653245ac984f6.tar.bz2
gentoo-2-03f0685c89174f502947c1b6196653245ac984f6.zip
Remove duplicate entries in DEPs, minor corrections / improvements to copy_test, python_test, call to dohtml
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/chaco')
-rw-r--r--dev-python/chaco/ChangeLog6
-rw-r--r--dev-python/chaco/chaco-4.3.0-r1.ebuild27
2 files changed, 17 insertions, 16 deletions
diff --git a/dev-python/chaco/ChangeLog b/dev-python/chaco/ChangeLog
index 270fa36429d2..551dc4a23b3e 100644
--- a/dev-python/chaco/ChangeLog
+++ b/dev-python/chaco/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/chaco
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.19 2013/04/15 09:45:43 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/ChangeLog,v 1.20 2013/04/15 15:12:42 idella4 Exp $
+
+ 15 Apr 2013; Ian Delaney <idella4@gentoo.org> chaco-4.3.0-r1.ebuild:
+ Remove duplicate entries in DEPs, minor corrections / improvements to
+ copy_test, python_test, call to dohtml
*chaco-4.3.0-r1 (15 Apr 2013)
diff --git a/dev-python/chaco/chaco-4.3.0-r1.ebuild b/dev-python/chaco/chaco-4.3.0-r1.ebuild
index cf6f88909baf..19276d4e54f7 100644
--- a/dev-python/chaco/chaco-4.3.0-r1.ebuild
+++ b/dev-python/chaco/chaco-4.3.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-4.3.0-r1.ebuild,v 1.1 2013/04/15 09:45:43 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-4.3.0-r1.ebuild,v 1.2 2013/04/15 15:12:42 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=python2_7
+PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 virtualx
@@ -22,9 +22,7 @@ RDEPEND=">=dev-python/enable-4
>=dev-python/traitsui-4[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
doc? (
- >=dev-python/enable-4
media-fonts/font-cursor-misc
media-fonts/font-misc-misc
!prefix? ( x11-base/xorg-server[xvfb] )
@@ -32,7 +30,6 @@ DEPEND="${RDEPEND}
dev-python/sphinx[${PYTHON_USEDEP}]
)
test? (
- >=dev-python/enable-4
media-fonts/font-cursor-misc
media-fonts/font-misc-misc
)"
@@ -45,25 +42,25 @@ python_compile_all() {
# Let's unclutter test phase. Tests need to be within "${BUILD_DIR}"/lib for paths to be read correctly
copy_tests() {
- cd "${BUILD_DIR}"/lib
- mkdir -p ${PN}/{shell,scales}
- cp -a "${S}"/${PN}/tests/ ${PN}/
- cp -a "${S}"/${PN}/shell/tests/ ${PN}/shell/
- cp -a "${S}"/${PN}/scales/tests/ ${PN}/scales/
+ cd "${BUILD_DIR}"/lib || die
+ mkdir -p ${PN}/{shell,scales} || die
+ cp -a "${S}"/${PN}/tests/ ${PN}/ || die
+ cp -a "${S}"/${PN}/shell/tests/ ${PN}/shell/ || die
+ cp -a "${S}"/${PN}/scales/tests/ ${PN}/scales/ || die
}
python_test() {
# skirt tests until fixed; https://github.com/enthought/chaco/issues/112
copy_tests || die
- VIRTUALX_COMMAND="nosetests -e test_estimate_default_scale* \
- -e test_tfrac_hours_04* -e test_tfrac_hours_05* \
- -e test_microsecond* -I border_test_case*" virtualmake
- rm -rf /${PN}/tests/ /${PN}/shell/ ${PN}/scales/ || die
+ VIRTUALX_COMMAND="nosetests" virtualmake -e 'test_estimate_default_scale*' \
+ -e 'test_tfrac_hours_04*' -e 'test_tfrac_hours_05*' \
+ -e 'test_microsecond*' -I 'border_test_case*'
+ rm -rf ${PN}/tests/ /${PN}/shell/ ${PN}/scales/ || die
}
python_install_all() {
distutils-r1_python_install_all
- use doc && dohtml -r docs/build/html
+ use doc && dohtml -r docs/build/html/
if use examples; then
docompress -x usr/share/doc/${PF}/examples/