summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 19:28:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-30 19:28:34 +0000
commitf107866a142c8dbfcf4c44e7e6cf374d59f121a3 (patch)
tree4fef73f835f25f6898b3ef19e75075450f69af3e /dev-python/bsddb3
parentUse PyPI mirrors. (diff)
downloadgentoo-2-f107866a142c8dbfcf4c44e7e6cf374d59f121a3.tar.gz
gentoo-2-f107866a142c8dbfcf4c44e7e6cf374d59f121a3.tar.bz2
gentoo-2-f107866a142c8dbfcf4c44e7e6cf374d59f121a3.zip
Delete older ebuilds.
(Portage version: 2.2.0_alpha2_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/ChangeLog7
-rw-r--r--dev-python/bsddb3/bsddb3-4.8.1.ebuild69
-rw-r--r--dev-python/bsddb3/bsddb3-4.8.3.ebuild76
-rw-r--r--dev-python/bsddb3/bsddb3-4.8.4.ebuild76
-rw-r--r--dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch26
5 files changed, 6 insertions, 248 deletions
diff --git a/dev-python/bsddb3/ChangeLog b/dev-python/bsddb3/ChangeLog
index f1170f1f36ea..9f3d2828dcfb 100644
--- a/dev-python/bsddb3/ChangeLog
+++ b/dev-python/bsddb3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bsddb3
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.57 2010/06/20 18:28:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.58 2010/10/30 19:28:33 arfrever Exp $
+
+ 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -bsddb3-4.8.1.ebuild, -bsddb3-4.8.3.ebuild,
+ -files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch, -bsddb3-4.8.4.ebuild:
+ Delete.
20 Jun 2010; Raúl Porcel <armin76@gentoo.org> bsddb3-5.0.0.ebuild:
sparc stable wrt #319731
diff --git a/dev-python/bsddb3/bsddb3-4.8.1.ebuild b/dev-python/bsddb3/bsddb3-4.8.1.ebuild
deleted file mode 100644
index 103720113606..000000000000
--- a/dev-python/bsddb3/bsddb3-4.8.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.1.ebuild,v 1.5 2010/03/20 16:20:48 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit db-use distutils multilib
-
-DESCRIPTION="Python bindings for Berkeley DB"
-HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm http://pypi.python.org/pypi/bsddb3"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc sparc x86"
-IUSE="doc"
-
-RDEPEND=">=sys-libs/db-4.6"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-DOCS="TODO.txt"
-
-src_compile() {
- local DB_VER
- if has_version sys-libs/db:4.8; then
- DB_VER="4.8"
- elif has_version sys-libs/db:4.7; then
- DB_VER="4.7"
- else
- DB_VER="4.6"
- fi
-
- sed -i \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- setup2.py setup3.py || die "sed failed"
-
- distutils_src_compile \
- "--berkeley-db=/usr" \
- "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
- "--berkeley-db-libdir=/usr/$(get_libdir)"
-
- if use doc; then
- mkdir html
- sphinx-build docs html || die "building docs failed"
- fi
-}
-
-src_test() {
- tests() {
- rm -fr /tmp/z-Berkeley_DB
- rm -f build
- ln -s build-${PYTHON_ABI} build
-
- echo "$(PYTHON)" test.py
- "$(PYTHON)" test.py
- }
- python_execute_function tests
-}
-
-src_install() {
- distutils_src_install
-
- rm -fr "${D}"usr/lib*/python*/site-packages/${PN}/tests
-
- use doc && dohtml -r html/*
-}
diff --git a/dev-python/bsddb3/bsddb3-4.8.3.ebuild b/dev-python/bsddb3/bsddb3-4.8.3.ebuild
deleted file mode 100644
index dd3c08cec508..000000000000
--- a/dev-python/bsddb3/bsddb3-4.8.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.3.ebuild,v 1.4 2010/04/11 12:45:44 nixnut Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit db-use distutils eutils multilib
-
-DESCRIPTION="Python bindings for Berkeley DB"
-HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm http://pypi.python.org/pypi/bsddb3"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~sparc ~x86"
-IUSE=""
-# Documentation missing in >=4.8.2 tarball.
-# IUSE="doc"
-
-RDEPEND=">=sys-libs/db-4.6"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-# doc? ( dev-python/sphinx )
-
-DOCS="TODO.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/${P}-BSDDB_TEST_PATH.patch"
-}
-
-src_compile() {
- local DB_VER
- if has_version sys-libs/db:4.8; then
- DB_VER="4.8"
- elif has_version sys-libs/db:4.7; then
- DB_VER="4.7"
- else
- DB_VER="4.6"
- fi
-
- sed -i \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- setup2.py setup3.py || die "sed failed"
-
- distutils_src_compile \
- "--berkeley-db=/usr" \
- "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
- "--berkeley-db-libdir=/usr/$(get_libdir)"
-
-# if use doc; then
-# mkdir html
-# sphinx-build docs html || die "Generation of documentation failed"
-# fi
-}
-
-src_test() {
- tests() {
- rm -f build
- ln -s build-${PYTHON_ABI} build
-
- echo BSDDB_TEST_PATH="${T}/tests-${PYTHON_ABI}" "$(PYTHON)" test.py
- BSDDB_TEST_PATH="${T}/tests-${PYTHON_ABI}" "$(PYTHON)" test.py
- }
- python_execute_function tests
-}
-
-src_install() {
- distutils_src_install
-
- rm -fr "${D}"usr/lib*/python*/site-packages/${PN}/tests
-
-# use doc && dohtml -r html/*
-}
diff --git a/dev-python/bsddb3/bsddb3-4.8.4.ebuild b/dev-python/bsddb3/bsddb3-4.8.4.ebuild
deleted file mode 100644
index cb85ca53484f..000000000000
--- a/dev-python/bsddb3/bsddb3-4.8.4.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.4.ebuild,v 1.1 2010/03/23 18:37:57 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit db-use distutils eutils multilib
-
-DESCRIPTION="Python bindings for Berkeley DB"
-HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm http://pypi.python.org/pypi/bsddb3"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE=""
-# Documentation missing in >=4.8.2 tarball.
-# IUSE="doc"
-
-RDEPEND=">=sys-libs/db-4.6"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-# doc? ( dev-python/sphinx )
-
-DOCS="TODO.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/${PN}-4.8.3-BSDDB_TEST_PATH.patch"
-}
-
-src_compile() {
- local DB_VER
- if has_version sys-libs/db:4.8; then
- DB_VER="4.8"
- elif has_version sys-libs/db:4.7; then
- DB_VER="4.7"
- else
- DB_VER="4.6"
- fi
-
- sed -i \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- setup2.py setup3.py || die "sed failed"
-
- distutils_src_compile \
- "--berkeley-db=/usr" \
- "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
- "--berkeley-db-libdir=/usr/$(get_libdir)"
-
-# if use doc; then
-# mkdir html
-# sphinx-build docs html || die "Generation of documentation failed"
-# fi
-}
-
-src_test() {
- tests() {
- rm -f build
- ln -s build-${PYTHON_ABI} build
-
- echo BSDDB_TEST_PATH="${T}/tests-${PYTHON_ABI}" "$(PYTHON)" test.py
- BSDDB_TEST_PATH="${T}/tests-${PYTHON_ABI}" "$(PYTHON)" test.py
- }
- python_execute_function tests
-}
-
-src_install() {
- distutils_src_install
-
- rm -fr "${D}"usr/lib*/python*/site-packages/${PN}/tests
-
-# use doc && dohtml -r html/*
-}
diff --git a/dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch b/dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch
deleted file mode 100644
index b4b6ee633b7b..000000000000
--- a/dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- Lib/bsddb/test/test_all.py
-+++ Lib/bsddb/test/test_all.py
-@@ -528,7 +528,9 @@
-
- # This path can be overriden via "set_test_path_prefix()".
- import os, os.path
--get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
-+get_new_path.prefix=os.environ.get("BSDDB_TEST_PATH")
-+if get_new_path.prefix is None:
-+ get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
- get_new_path.num=0
-
- def get_test_path_prefix() :
---- Lib3/bsddb/test/test_all.py
-+++ Lib3/bsddb/test/test_all.py
-@@ -528,7 +528,9 @@
-
- # This path can be overriden via "set_test_path_prefix()".
- import os, os.path
--get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
-+get_new_path.prefix=os.environ.get("BSDDB_TEST_PATH")
-+if get_new_path.prefix is None:
-+ get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
- get_new_path.num=0
-
- def get_test_path_prefix() :