summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-11-18 20:10:08 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-11-18 20:10:08 +0000
commitaaa973c83b9304ea94b179cd244474b36b4f5cf0 (patch)
tree9f916b06f7b66f30d5bac640850c18072966be72 /dev-python/boto
parentDrop patch "Install dracut-install into libexec dir instead of lib" (diff)
downloadgentoo-2-aaa973c83b9304ea94b179cd244474b36b4f5cf0.tar.gz
gentoo-2-aaa973c83b9304ea94b179cd244474b36b4f5cf0.tar.bz2
gentoo-2-aaa973c83b9304ea94b179cd244474b36b4f5cf0.zip
bup for glance
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.34.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 77b58623e826..92db3940afc6 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.99 2014/07/10 23:52:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.100 2014/11/18 20:10:08 prometheanfire Exp $
+
+*boto-2.34.0 (18 Nov 2014)
+
+ 18 Nov 2014; Matthew Thode <prometheanfire@gentoo.org> +boto-2.34.0.ebuild:
+ bup for glance
*boto-2.31.1 (10 Jul 2014)
diff --git a/dev-python/boto/boto-2.34.0.ebuild b/dev-python/boto/boto-2.34.0.ebuild
new file mode 100644
index 000000000000..6411b68ca04e
--- /dev/null
+++ b/dev-python/boto/boto-2.34.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.34.0.ebuild,v 1.1 2014/11/18 20:10:08 prometheanfire Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}