summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-15 23:15:17 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-15 23:15:17 +0000
commitc8ddf33fe58febfb5dbf3a146f9e8ed8c45b7f38 (patch)
treefa911a88be8072ac2925235cf00eedb10f3e6699 /dev-python/atpy
parentmask latest luatex as it breaks with current texlive (diff)
downloadgentoo-2-c8ddf33fe58febfb5dbf3a146f9e8ed8c45b7f38.tar.gz
gentoo-2-c8ddf33fe58febfb5dbf3a146f9e8ed8c45b7f38.tar.bz2
gentoo-2-c8ddf33fe58febfb5dbf3a146f9e8ed8c45b7f38.zip
Fix sqlite3 module dependency -- the package supports only built-in Python sqlite3, not external pysqlite2.
(Portage version: 2.2.0_alpha152/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/atpy')
-rw-r--r--dev-python/atpy/ChangeLog8
-rw-r--r--dev-python/atpy/atpy-0.9.6.ebuild8
2 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/atpy/ChangeLog b/dev-python/atpy/ChangeLog
index 6ff535bcadcf..e9774061d389 100644
--- a/dev-python/atpy/ChangeLog
+++ b/dev-python/atpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/atpy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/atpy/ChangeLog,v 1.7 2012/08/02 17:31:55 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/atpy/ChangeLog,v 1.8 2013/01/15 23:15:17 mgorny Exp $
+
+ 15 Jan 2013; Michał Górny <mgorny@gentoo.org> atpy-0.9.6.ebuild:
+ Fix sqlite3 module dependency -- the package supports only built-in Python
+ sqlite3, not external pysqlite2.
*atpy-0.9.6 (02 Aug 2012)
diff --git a/dev-python/atpy/atpy-0.9.6.ebuild b/dev-python/atpy/atpy-0.9.6.ebuild
index 45ea5c43a749..cc9ed91a5e7f 100644
--- a/dev-python/atpy/atpy-0.9.6.ebuild
+++ b/dev-python/atpy/atpy-0.9.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/atpy/atpy-0.9.6.ebuild,v 1.1 2012/08/02 17:31:54 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/atpy/atpy-0.9.6.ebuild,v 1.2 2013/01/15 23:15:17 mgorny Exp $
EAPI="2"
@@ -8,6 +8,9 @@ PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython"
+PYTHON_USE_WITH=sqlite
+PYTHON_USE_WITH_OPT=sqlite
+
inherit distutils
MYPN=ATpy
@@ -23,7 +26,6 @@ RDEPEND="dev-python/numpy
hdf5? ( dev-python/h5py )
mysql? ( dev-python/mysql-python )
postgres? ( dev-db/pygresql )
- sqlite? ( dev-python/pysqlite )
votable? ( dev-python/vo )"
DEPEND=">=dev-python/numpy-1.3"