summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-02-12 08:03:26 +0000
committerIan Delaney <idella4@gentoo.org>2014-02-12 08:03:26 +0000
commitdf4cf6c3379ba2d2f8f328c2222c618aee600d0a (patch)
tree825232628d146e330b53454efb8d7bfb5e8f8418 /dev-python/astroid
parentFix typo, bug #501036. Thanks to Kalin KOZHUHAROV for noticing. (diff)
downloadgentoo-2-df4cf6c3379ba2d2f8f328c2222c618aee600d0a.tar.gz
gentoo-2-df4cf6c3379ba2d2f8f328c2222c618aee600d0a.tar.bz2
gentoo-2-df4cf6c3379ba2d2f8f328c2222c618aee600d0a.zip
this is an updated clone if astng which has been renamed and the upstream repo re-located to bitbucket, py3.3 support added, test phase and install updated
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/ChangeLog10
-rw-r--r--dev-python/astroid/Manifest3
-rw-r--r--dev-python/astroid/astroid-1.0.1.ebuild48
-rw-r--r--dev-python/astroid/metadata.xml16
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/astroid/ChangeLog b/dev-python/astroid/ChangeLog
new file mode 100644
index 000000000000..d99e6e96f428
--- /dev/null
+++ b/dev-python/astroid/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/astroid
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/ChangeLog,v 1.1 2014/02/12 08:03:26 idella4 Exp $
+
+*astroid-1.0.1 (12 Feb 2014)
+
+ 12 Feb 2014; Ian Delaney <idella4@gentoo.org> +astroid-1.0.1.ebuild,
+ +metadata.xml:
+ this is an updated clone if astng which has been renamed and the upstream repo
+ re-located to bitbucket, py3.3 support added, test phase and install updated
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
new file mode 100644
index 000000000000..29fdfece8e1e
--- /dev/null
+++ b/dev-python/astroid/Manifest
@@ -0,0 +1,3 @@
+DIST astroid-1.0.1.tar.gz 112597 SHA256 46c2b57ab1eedd1b0931c075c21644445dd589a92481e938cf66495e0f205fda SHA512 277353f30b8f3ce509f65f3f4b5f6da70bd96483ef22cb03beebe141c9eece1baa2989b40b545ed71952619814ba049796b13727d97531d2630ebfcbf1cb6cff WHIRLPOOL 85c83ab850bc0d9d692995127e8d51803aca824425e2afe204479437b618b2821ed3ede3d54af043c9a164d0e419b54647910b1e5785c0fcdeadb1c56fa7c818
+EBUILD astroid-1.0.1.ebuild 1509 SHA256 f28cb21ef22cb756a61b1d7a77778ad6bc9e922051fd63fb2c23d9c8575feffa SHA512 c78e3f0858ab46ad2e6c85f6da581f2b22c40593d3455a90c0062d1bd8b7575f9a7afed3364deac9e81d228b5887aad30ddd5e6bf51677011b0d49060e455aef WHIRLPOOL d09e2adb06878a1a43097ce0fc525e7b2af108d1b76d8cdcf5ab6f594c887548d5c1c5d0dd08bbee6cc5a94c834b154dcb8519e47ffd73400a02d70af55fbeb3
+MISC metadata.xml 903 SHA256 30c79ff0c1bb5877b5f42686900f1b7c7edefd76834a5d96a1e7d3a64c6b91ab SHA512 edb464d771c46b5d66ab0246f7c6e8901863a197d70ae9139a38c61d92aa4a6ce8bbc4db4b236b61b9ecd9c4e428b6be7c78328a0743a5fa8ac4407b794dba14 WHIRLPOOL 6e0d3de24dd81950bcdc82a85f725d65b739f36e66a248b14d8b34894fa66c51ef3e40f57670e81b49baac459c7ca8c4454c2e3cc8f94e5c4f73aa55770f0118
diff --git a/dev-python/astroid/astroid-1.0.1.ebuild b/dev-python/astroid/astroid-1.0.1.ebuild
new file mode 100644
index 000000000000..4850d91a767a
--- /dev/null
+++ b/dev-python/astroid/astroid-1.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.0.1.ebuild,v 1.1 2014/02/12 08:03:26 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+# Version specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+# Required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # https://bitbucket.org/logilab/astroid/issue/8/
+ sed -e "s/test_numpy_crash/_&/" -i test/unittest_regrtest.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://bitbucket.org/logilab/astroid/issue/1/test-suite-fails-in-0243-under-py32-pypy
+ # https://bitbucket.org/logilab/astroid/issue/16/1-test-fail-test_socket_build-under-pypy
+ # test_hashlib fails only in py3.2
+ python setup.py build
+
+ pushd build/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy* ]]; then
+ sed -e 's:test_socket_build:_&:' -i ${PN}/test/unittest_builder.py || die
+ elif [[ "${EPYTHON}" == 'python3.2' ]]; then
+ sed -e 's:test_hashlib:_&:' -i ${PN}/test/unittest_brain.py || die
+ fi
+ PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null
+}
diff --git a/dev-python/astroid/metadata.xml b/dev-python/astroid/metadata.xml
new file mode 100644
index 000000000000..fbf20bcee313
--- /dev/null
+++ b/dev-python/astroid/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">The aim of this module is to provide a common base representation of
+ python source code for projects such as pychecker, pyreverse,
+ pylint... Well, actually the development of this library is
+ essentially governed by pylint's needs.
+ It provides a compatible representation which comes from the _ast
+ module. It rebuilds the tree generated by the builtin _ast module by
+ recursively walking down the AST and building an extended ast (let's
+ call it astng ;). The new node classes have additional methods and
+ attributes for different usages. They include some support for static
+ inference and local name scopes. Furthermore, astng builds partial
+ trees by inspecting living objects.</longdescription>
+</pkgmetadata>