summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-04-22 18:35:24 +0000
committerSven Vermeulen <swift@gentoo.org>2013-04-22 18:35:24 +0000
commit5d8b3ea8f9e1278494d8e65005279e94d37c12a7 (patch)
treecf2bc0761a4660c1a5b1f0b6f600f39cfa4d26c6 /dev-python/apse
parentFix bug #466650 - SLOT swig-1 (diff)
downloadgentoo-2-5d8b3ea8f9e1278494d8e65005279e94d37c12a7.tar.gz
gentoo-2-5d8b3ea8f9e1278494d8e65005279e94d37c12a7.tar.bz2
gentoo-2-5d8b3ea8f9e1278494d8e65005279e94d37c12a7.zip
Use SLOTed swig-1
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'dev-python/apse')
-rw-r--r--dev-python/apse/ChangeLog8
-rw-r--r--dev-python/apse/apse-0.2-r3.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/apse/ChangeLog b/dev-python/apse/ChangeLog
index bf90068242e6..40a611f447a1 100644
--- a/dev-python/apse/ChangeLog
+++ b/dev-python/apse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/apse
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apse/ChangeLog,v 1.12 2013/01/20 00:45:10 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apse/ChangeLog,v 1.13 2013/04/22 18:35:24 swift Exp $
+
+*apse-0.2-r3 (22 Apr 2013)
+
+ 22 Apr 2013; Sven Vermeulen <swift@gentoo.org> +apse-0.2-r3.ebuild:
+ Using SLOTed swig-1.3, fixes dependency handling when both swig-2 and swig-1
+ are build-time deps
*apse-0.2-r2 (20 Jan 2013)
diff --git a/dev-python/apse/apse-0.2-r3.ebuild b/dev-python/apse/apse-0.2-r3.ebuild
new file mode 100644
index 000000000000..d16570749ac8
--- /dev/null
+++ b/dev-python/apse/apse-0.2-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apse/apse-0.2-r3.ebuild,v 1.1 2013/04/22 18:35:24 swift Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_P="Apse-${PV}"
+
+DESCRIPTION="Approximate String Matching in Python."
+HOMEPAGE="http://www.personal.psu.edu/staff/i/u/iua1/python/apse/"
+SRC_URI="http://www.personal.psu.edu/staff/i/u/iua1/python/${PN}/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-lang/swig:1"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Prevent the build system from calling swig over and over again.
+ sed -i -e 's:Apse.i:Apse_wrap.c:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ set -- swig1.3 -python -o Apse_wrap.c Apse.i
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+python_test() {
+ "${PYTHON}" test/test_Apse.py || die "Tests fail with ${EPYTHON}"
+}