summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-28 06:03:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-28 06:03:23 +0000
commit7d5652ae29fc5067007622ae757fa6740e13e7d4 (patch)
tree427308e4e3e257fef97739aece60276bf45fdafa /dev-python/anyvc
parentarm stable, bug #419473 (diff)
downloadgentoo-2-7d5652ae29fc5067007622ae757fa6740e13e7d4.tar.gz
gentoo-2-7d5652ae29fc5067007622ae757fa6740e13e7d4.tar.bz2
gentoo-2-7d5652ae29fc5067007622ae757fa6740e13e7d4.zip
Bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/anyvc')
-rw-r--r--dev-python/anyvc/ChangeLog10
-rw-r--r--dev-python/anyvc/anyvc-0.3.7.1.ebuild50
2 files changed, 57 insertions, 3 deletions
diff --git a/dev-python/anyvc/ChangeLog b/dev-python/anyvc/ChangeLog
index 70b522e8e123..872c91819f6a 100644
--- a/dev-python/anyvc/ChangeLog
+++ b/dev-python/anyvc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/anyvc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/anyvc/ChangeLog,v 1.5 2010/10/30 16:25:34 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anyvc/ChangeLog,v 1.6 2012/06/28 06:03:23 patrick Exp $
+
+*anyvc-0.3.7.1 (28 Jun 2012)
+
+ 28 Jun 2012; Patrick Lauer <patrick@gentoo.org> +anyvc-0.3.7.1.ebuild:
+ Bump
*anyvc-0.3.5 (30 Oct 2010)
@@ -25,4 +30,3 @@
23 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+anyvc-0.3.1.ebuild, +metadata.xml:
Initial addition. Ebuild written by me.
-
diff --git a/dev-python/anyvc/anyvc-0.3.7.1.ebuild b/dev-python/anyvc/anyvc-0.3.7.1.ebuild
new file mode 100644
index 000000000000..dd54c3970f3c
--- /dev/null
+++ b/dev-python/anyvc/anyvc-0.3.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anyvc/anyvc-0.3.7.1.ebuild,v 1.1 2012/06/28 06:03:23 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+DESCRIPTION="Library to access any version control system"
+HOMEPAGE="http://pypi.python.org/pypi/anyvc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bazaar doc git mercurial subversion"
+
+RDEPEND="dev-python/apipkg
+ dev-python/execnet
+ dev-python/py
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-python/dulwich )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-python/subvertpy )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ sphinx-build -b html docs docs_output || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs_output > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}