summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-03-28 22:36:40 +0000
committerStuart Herbert <stuart@gentoo.org>2004-03-28 22:36:40 +0000
commitfe05b24b15a7acba818b5393894c013bd8a3838b (patch)
treed372e8ec11eb338c18ff39451a49ed407c9cc8c7 /dev-php
parentFix for bug #39248 (Manifest recommit) (diff)
downloadgentoo-2-fe05b24b15a7acba818b5393894c013bd8a3838b.tar.gz
gentoo-2-fe05b24b15a7acba818b5393894c013bd8a3838b.tar.bz2
gentoo-2-fe05b24b15a7acba818b5393894c013bd8a3838b.zip
Auto-apply patch depending on which kernel is installed
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpsysinfo/ChangeLog7
-rw-r--r--dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild10
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-php/phpsysinfo/ChangeLog b/dev-php/phpsysinfo/ChangeLog
index e680a9368509..6ab144238cbe 100644
--- a/dev-php/phpsysinfo/ChangeLog
+++ b/dev-php/phpsysinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/phpsysinfo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/ChangeLog,v 1.10 2004/03/28 22:30:57 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/ChangeLog,v 1.11 2004/03/28 22:36:40 stuart Exp $
+
+*phpsysinfo-2.1-r2 (28 Mar 2004)
+
+ 28 Mar 2004; Stuart Herbert <stuart@gentoo.org> phpsysinfo-2.1-r2.ebuild:
+ Auto-apply the 2.5 kernel patch if we're running on a 2.5 / 2.6 kernel
28 Mar 2004; Stuart Herbert <stuart@gentoo.org> :
Included working 2.5/2.6 kernel patch from Stephen Reindl
diff --git a/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild b/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild
index 7ae98f115ef8..7b9ecd220c44 100644
--- a/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild
+++ b/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild,v 1.1 2004/03/28 22:30:57 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpsysinfo/phpsysinfo-2.1-r2.ebuild,v 1.2 2004/03/28 22:36:40 stuart Exp $
-inherit eutils
+inherit eutils kernel-mod
MY_PN="phpSysInfo"
MY_P="${MY_PN}-${PV}"
@@ -26,7 +26,11 @@ src_unpack() {
mv ${P}/debian ${S}
rmdir ${P}
epatch ${S}/debian/patches/urlencoded-security-fix.diff
- epatch ${FILESDIR}/fix_memory_display_kernel2.5.diff.gz
+
+ APPLY_25PATCH=0
+ kernel-mod_is_2_5_kernel && APPLY_25PATCH=1
+ kernel-mod_is_2_6_kernel && APPLY_25PATCH=1
+ [ "$APPLY_25PATCH" = "1" ] && epatch ${FILESDIR}/fix_memory_display_kernel2.5.diff.gz
}
src_install() {